diff mbox series

[bug#40305] gnu: Add emacs-elf-mode

Message ID 875zeo2btu.fsf@asu.edu
State Accepted
Headers show
Series [bug#40305] gnu: Add emacs-elf-mode | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 29, 2020, 1:23 a.m. UTC
Hi Guix!

This almost the last emacs package I use that I could not get from guix.

elf-mode shows symbol information in elf object files.

Thanks!

John

Comments

Nicolas Goaziou April 1, 2020, 8:45 a.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> * gnu/packages/emacs-xyz.scm (emacs-elf-mode): New variable.

Thank you!

I fixed the license field, reworded the description, and applied it as
31e47945d37a738fccbb5c7e304f01ccfdd45a68.

Regards,
diff mbox series

Patch

>From 4c8a0421561f1d2325028563bcd0060edf5a3d25 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:42:14 -0700
Subject: [PATCH] gnu: Add emacs-elf-mode.

* gnu/packages/emacs-xyz.scm (emacs-elf-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..499164ab13 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21776,3 +21777,24 @@  enables modal editing and composition of commands, too.  It combines ideas of
 other Editors like Vim or Kakoune and tries to align them with regular Emacs
 conventions.")
     (license license:gpl3+)))
+
+(define-public emacs-elf-mode
+  (package
+    (name "emacs-elf-mode")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/abo-abo/elf-mode")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0cbvjbk2893ag1iy8ggixpirfiyhssm7fii96hb9jqdz874cdl0k"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/abo-abo/elf-mode")
+    (synopsis "Show symbol list when opening a binary file in Emacs")
+    (description "Show symbol list when opening a binary file in Emacs.")
+    (license license:gpl2+)))
-- 
2.26.0