diff mbox series

[bug#40417] Add emacs-magit-annex

Message ID 875zegcq6w.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#40417] Add emacs-magit-annex | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 3, 2020, 7:41 p.m. UTC

Comments

Kyle Meyer April 3, 2020, 10:52 p.m. UTC | #1
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> +(define-public emacs-magit-annex
> +  (package
> +    (name "emacs-magit-annex")
> +    (version "1.7.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/magit/magit-annex.git")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "07r0d2i1hws63wfv1jys63r3lmrl4ywwi76gi7srwhzhqdr1af0n"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-magit" ,emacs-magit)
> +       ("emacs-magit-popup" ,emacs-magit-popup)
> +       ("transient" ,emacs-transient)))

It looks like emacs-magit uses a revision that follows the popup to
transient switch that happened after the 2.90.1 release.  Magit-annex's
master branch has been updated to work with transient and will be
released along with the next release of Magit.

So, perhaps it'd make sense to drop the emacs-magit-popup input and use
an unreleased revision here until the next release of Magit and
Magit-annex.

Thanks for packaging Magit-annex!
Christine Lemmer-Webber April 5, 2020, 3:51 p.m. UTC | #2
Kyle Meyer writes:

> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> +(define-public emacs-magit-annex
>> +  (package
>> +    (name "emacs-magit-annex")
>> +    (version "1.7.1")
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url "https://github.com/magit/magit-annex.git")
>> +                    (commit (string-append "v" version))))
>> +              (file-name (git-file-name name version))
>> +              (sha256
>> +               (base32
>> +                "07r0d2i1hws63wfv1jys63r3lmrl4ywwi76gi7srwhzhqdr1af0n"))))
>> +    (build-system emacs-build-system)
>> +    (propagated-inputs
>> +     `(("emacs-magit" ,emacs-magit)
>> +       ("emacs-magit-popup" ,emacs-magit-popup)
>> +       ("transient" ,emacs-transient)))
>
> It looks like emacs-magit uses a revision that follows the popup to
> transient switch that happened after the 2.90.1 release.  Magit-annex's
> master branch has been updated to work with transient and will be
> released along with the next release of Magit.

That may explain why I had to manually insert the @ keybinding it
supposedly should have done automatically.

I'm a little confused since I haven't been following magit though.
"popup to transient switch"?

> So, perhaps it'd make sense to drop the emacs-magit-popup input and use
> an unreleased revision here until the next release of Magit and
> Magit-annex.

I think once I am unconfused I can probably do this. :)

> Thanks for packaging Magit-annex!
Kyle Meyer April 5, 2020, 4:13 p.m. UTC | #3
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> Kyle Meyer writes:

>> It looks like emacs-magit uses a revision that follows the popup to
>> transient switch that happened after the 2.90.1 release.  Magit-annex's
>> master branch has been updated to work with transient and will be
>> released along with the next release of Magit.
>
> That may explain why I had to manually insert the @ keybinding it
> supposedly should have done automatically.

Correct.

> I'm a little confused since I haven't been following magit though.
> "popup to transient switch"?

Sorry, here's more context: Magit's popup interface used to be defined
with Magit-Popup.  Jonas Bernoulli wrote Transient to replace
Magit-Popup [^1].  As of 1ed3febf (Merge branch 'transient' [#3728],
2019-02-14), all of Magit's popups have been rewritten with Transient.
That change hasn't made it into a release yet, but it happened before
the revision that emacs-magit is built from.

[^1]: https://emacsair.me/2019/02/14/transient-0.1/
diff mbox series

Patch

From 5d6e5c4bd7809756cba5c9f317b7814052d940ae Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Thu, 2 Apr 2020 15:03:27 -0400
Subject: [PATCH] gnu: Add emacs-magit-annex.

* gnu/packages/emacs-xyz.scm (emacs-magit-annex): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8fcc686613..5800b32084 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -448,6 +448,30 @@  these arguments.  The prototypical use is for the command to call an external
 process, passing on the arguments as command line arguments.")
     (license license:gpl3+)))
 
+(define-public emacs-magit-annex
+  (package
+    (name "emacs-magit-annex")
+    (version "1.7.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/magit/magit-annex.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07r0d2i1hws63wfv1jys63r3lmrl4ywwi76gi7srwhzhqdr1af0n"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-magit" ,emacs-magit)
+       ("emacs-magit-popup" ,emacs-magit-popup)
+       ("transient" ,emacs-transient)))
+    (home-page "https://github.com/magit/magit-annex/")
+    (synopsis "Git-annex support for Magit")
+    (description
+     "Magit-annex adds a few git-annex operations to the Magit interface.")
+    (license license:gpl3+)))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")
-- 
2.26.0