diff mbox series

[bug#40568] gnu: Add rtl8821ce-linux-module.

Message ID 875ze5dm5d.fsf@rohleder.de
State Accepted
Headers show
Series [bug#40568] gnu: Add rtl8821ce-linux-module. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder April 12, 2020, 10:38 a.m. UTC
Hi Tobias,

Tobias Geerinckx-Rice via Guix-patches via <guix-patches@gnu.org>
writes:
> Yay!  Thank her for the patch.

Will do.

Thank you for your review!
Your suggestions are in the patch appended.

> This ought to be a little longer.  I can throw something together if
> you're without inspiration.

Yes, please do.

> The AUR package says ‘with firmware’, which would be problematic if
> I'd actually found any.  The README also mentions firmware at the very
> end.  Do you know what they mean?  Does this package work out of the
> box with Linux-Libre?  Is that only for Bluetooth?

idk what firmware they mean. This driver depends on cfg80211 which
shouldnt be a problem.
yes, this works out of the box with Linux-Libre (and not Libre) on the
laptop I have tested.
I havent tested bluetooth at all.


Kind Regards,
mike

Comments

Danny Milosavljevic April 13, 2020, 8:19 p.m. UTC | #1
Hi,

the upstream README mentions having to add "pci=noaer" to the kernel command
line sometimes.  Did you have to do that?

It also hints on "firmware" being necessary for "BlueTooth".
Michael Rohleder April 14, 2020, 4:38 a.m. UTC | #2
Danny Milosavljevic <dannym@scratchpost.org> writes:
> the upstream README mentions having to add "pci=noaer" to the kernel command
> line sometimes.  Did you have to do that?

No, I didnt, it worked w/o.
Ludovic Courtès May 8, 2020, 2:29 p.m. UTC | #3
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

>> The AUR package says ‘with firmware’, which would be problematic if
>> I'd actually found any.  The README also mentions firmware at the very
>> end.  Do you know what they mean?  Does this package work out of the
>> box with Linux-Libre?  Is that only for Bluetooth?
>
> idk what firmware they mean. This driver depends on cfg80211 which
> shouldnt be a problem.
> yes, this works out of the box with Linux-Libre (and not Libre) on the
> laptop I have tested.
> I havent tested bluetooth at all.

[...]

> From b87d051b0ca74550df619e3cc8ed70e8f77f6e99 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Sun, 12 Apr 2020 12:06:31 +0200
> Subject: [PATCH] gnu: Add rtl8821ce-linux-module.
>
> * gnu/packages/linux.scm (rtl8821ce-linux-module): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From b87d051b0ca74550df619e3cc8ed70e8f77f6e99 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 12 Apr 2020 12:06:31 +0200
Subject: [PATCH] gnu: Add rtl8821ce-linux-module.

* gnu/packages/linux.scm (rtl8821ce-linux-module): New variable.
---
 gnu/packages/linux.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0be50c11e0..2365d309e4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1057,6 +1057,41 @@  and frame injection.  It provides a @code{88XXau} kernel module that supports
 RTL8812AU, RTL8821AU, and RTL8814AU chips.")
       (license license:gpl2+))))
 
+(define-public rtl8821ce-linux-module
+  (let ((commit "69765eb288a8dfad3b055b906760b53e02ab1dea")
+        (revision "0"))
+    (package
+      (name "rtl8821ce-linux-module")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tomaspinho/rtl8821ce.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "17jiw25k74kv5lnvgycvj2g1n06hbrpjz6p4znk4a62g136rhn4s"))))
+      (build-system linux-module-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (replace 'build
+             (lambda* (#:key (make-flags '()) inputs #:allow-other-keys)
+               (setenv "CC" "gcc")
+               (invoke "make"
+                       (string-append "KSRC="
+                                      (assoc-ref inputs "linux-module-builder")
+                                      "/lib/modules/build")
+                       ))))
+         #:tests? #f))
+      (home-page "https://github.com/tomaspinho/rtl8821ce")
+      (synopsis "Linux driver for Realtek RTL8821CE wireless network adapters")
+      (description "This is Realtek's RTL8821CE Linux driver for wireless
+network adapters.")
+      (license license:gpl2))))
+
 (define-public vhba-module
   (package
     (name "vhba-module")
-- 
2.26.0