diff mbox series

[bug#41206] gnu: Add python-selenium

Message ID 875zd1ie80.fsf@alice.lan
State Accepted
Headers show
Series [bug#41206] gnu: Add python-selenium | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein May 12, 2020, 11:29 a.m. UTC
---
 gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès May 15, 2020, 10:25 a.m. UTC | #1
Hi,

Edouard Klein <edk@beaver-labs.com> skribis:

> ---
>  gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)

[...]

> +    (synopsis "Python bindings for Selenium")
> +    (description "Selenium enables web browser automation.
> +Selenium specifically provides infrastructure for the W3C WebDriver specification
> +— a platform and language-neutral coding interface compatible with all
> +major web browsers.")

I added a commit log that follows our convention and committed.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9be92053b1..32a4d2b756 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3746,3 +3746,26 @@  in Python with a focus on correctness and simplicity.
 Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
 it provides an elegant coroutine-based API.")
     (license license:bsd-3)))
+
+(define-public python-selenium
+  (package
+    (name "python-selenium")
+    (version "3.141.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "selenium" version))
+       (sha256
+        (base32
+         "039hf9knvl4s3hp21bzwsp1g5ri9gxsh504dp48lc6nr1av35byy"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-urllib3" ,python-urllib3)))
+    (home-page
+     "https://github.com/SeleniumHQ/selenium/")
+    (synopsis "Python bindings for Selenium")
+    (description "Selenium enables web browser automation.
+Selenium specifically provides infrastructure for the W3C WebDriver specification
+— a platform and language-neutral coding interface compatible with all
+major web browsers.")
+    (license license:asl2.0)))