diff mbox series

[bug#42468] gnu: patchelf: Update to 0.11.

Message ID 875zagbwkv.fsf@rohleder.de
State Accepted
Headers show
Series [bug#42468] gnu: patchelf: Update to 0.11. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder July 21, 2020, 5:35 p.m. UTC

Comments

Marius Bakke July 21, 2020, 9:30 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/elf.scm (patchelf): Update to 0.11.

Applied, thanks!

Btw, is your email signing key available somewhere?
Marius Bakke July 21, 2020, 11:44 p.m. UTC | #2
Marius Bakke <marius@gnu.org> writes:

> Michael Rohleder <mike@rohleder.de> writes:
>
>> * gnu/packages/elf.scm (patchelf): Update to 0.11.
>
> Applied, thanks!

Uh, I did not realize patchelf had 700+ dependencies (because it is used
for GHC), so I reverted this on 'master' and applied it on 'staging'
instead.

You can check the amount of rebuilds a package change will cause with
'guix refresh -l patchelf'.  It's good practice to use --subject-prefix
with 'PATCH staging' or 'PATCH core-updates' when emailing patches to
prevent overworked reviewers from breaking master on your behalf.  ;-)

Sorry for the mishap!
Michael Rohleder July 22, 2020, 1:29 a.m. UTC | #3
Marius Bakke <marius@gnu.org> writes:
> Uh, I did not realize patchelf had 700+ dependencies (because it is used
> for GHC), so I reverted this on 'master' and applied it on 'staging'
> instead.
>
> You can check the amount of rebuilds a package change will cause with
> 'guix refresh -l patchelf'.  It's good practice to use --subject-prefix
> with 'PATCH staging' or 'PATCH core-updates' when emailing patches to
> prevent overworked reviewers from breaking master on your behalf.  ;-)
>
> Sorry for the mishap!
>

Uh, yes, sorry for your wasted time!

I checked the dependencies and wanted to send to staging, but before
sending I got distracted from realworld and then forgot the prefix in
the subject (and was offline till now)... Sorry! I have to be more
careful next time!
Marius Bakke July 25, 2020, 2:43 p.m. UTC | #4
Michael Rohleder <mike@rohleder.de> writes:

> Marius Bakke <marius@gnu.org> writes:
>> Uh, I did not realize patchelf had 700+ dependencies (because it is used
>> for GHC), so I reverted this on 'master' and applied it on 'staging'
>> instead.
>>
>> You can check the amount of rebuilds a package change will cause with
>> 'guix refresh -l patchelf'.  It's good practice to use --subject-prefix
>> with 'PATCH staging' or 'PATCH core-updates' when emailing patches to
>> prevent overworked reviewers from breaking master on your behalf.  ;-)
>>
>> Sorry for the mishap!
>>
>
> Uh, yes, sorry for your wasted time!
>
> I checked the dependencies and wanted to send to staging, but before
> sending I got distracted from realworld and then forgot the prefix in
> the subject (and was offline till now)... Sorry! I have to be more
> careful next time!

No worries, we don't really expect contributors to know about these
things.  Sorry if my comment sounded angry, it was late.  ;-)

You've been around a while now, consider applying for commit access so
you can break master all by yourself, by the way!
diff mbox series

Patch

From c2d4b9b77fcc131294e6c2433b706e8401f8cc32 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 21 Jul 2020 19:32:50 +0200
Subject: [PATCH] gnu: patchelf: Update to 0.11.

* gnu/packages/elf.scm (patchelf): Update to 0.11.
---
 gnu/packages/elf.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 3aabc6e927..48558d5f14 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Mark Wielaard <mark@klomp.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -214,7 +215,7 @@  static analysis of the ELF binaries at hand.")
 (define-public patchelf
   (package
     (name "patchelf")
-    (version "0.10")
+    (version "0.11")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -223,7 +224,7 @@  static analysis of the ELF binaries at hand.")
                    "/patchelf-" version ".tar.bz2"))
              (sha256
               (base32
-               "1wzwvnlyf853hw9zgqq5522bvf8gqadk8icgqa41a5n7593csw7n"))))
+               "16ms3ijcihb88j3x6cl8cbvhia72afmfcphczb9cfwr0gbc22chx"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
-- 
2.27.0