diff mbox series

[bug#44024] gnu: emacs-request: Update to latest commit.

Message ID 875z7bp6yi.fsf@posteo.net
State Accepted
Headers show
Series [bug#44024] gnu: emacs-request: Update to latest commit. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Niklas Eklund Oct. 15, 2020, 8:31 p.m. UTC
This patch updates emacs-request to the latest commit on git. The reason for
updating the package is that early this year a patch was merged which allowed
emacs-request to utilize the auth-source package providing a more convenient
experience for users and package developers.

Comments

Nicolas Goaziou Oct. 15, 2020, 9:54 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> This patch updates emacs-request to the latest commit on git. The reason for
> updating the package is that early this year a patch was merged which allowed
> emacs-request to utilize the auth-source package providing a more convenient
> experience for users and package developers.

Thank you.

Could you add a comment explaining the above at the top of the package
definition and send it again?

Regards,
diff mbox series

Patch

From 7236dcf7c836cec8562df3d47ba8c2bc27bfdf0d Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 15 Oct 2020 22:23:58 +0200
Subject: [PATCH] gnu: emacs-request: Update to latest commit.

* gnu/packages/emacs-xyz.scm (emacs-request): Update to latest commit.
---
 gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++++++------------------
 1 file changed, 23 insertions(+), 21 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09984bc704..cbdc9d4234 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6910,29 +6910,31 @@  parallel.")
     (license license:gpl3+)))
 
 (define-public emacs-request
-  (package
-    (name "emacs-request")
-    (version "0.3.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/tkf/emacs-request")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1djywhvvb6kwdj0nd3axjvb7k2g06dzkc6hsf29w9rsk96vr8ryl"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:tests? #f)) ; requires network access.
-    (propagated-inputs
-     `(("emacs-deferred" ,emacs-deferred)))
-    (home-page "https://github.com/tkf/emacs-request")
-    (synopsis "Package for speaking HTTP in Emacs Lisp")
-    (description "This package provides a HTTP request library with multiple
+  (let ((commit "d02d1347ffdf138cffd380cbeac62ac8732036ef")
+        (revision "0"))
+    (package
+      (name "emacs-request")
+      (version (git-version "0.3.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/tkf/emacs-request")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1rkpakzish2d470ca15yq3k0m1j7a2lrkvvddcyvc2rx0sncsdjs"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:tests? #f))                  ; requires network access.
+      (propagated-inputs
+       `(("emacs-deferred" ,emacs-deferred)))
+      (home-page "https://github.com/tkf/emacs-request")
+      (synopsis "Package for speaking HTTP in Emacs Lisp")
+      (description "This package provides a HTTP request library with multiple
 backends.  It supports url.el which is shipped with Emacs and the curl command
 line program.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-rudel
   (package
-- 
2.28.0