diff mbox series

[bug#44797] gnu: Add emacs-orderless

Message ID 875z5x8qi0.fsf@posteo.net
State Accepted
Headers show
Series [bug#44797] gnu: Add emacs-orderless | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Nov. 22, 2020, 1:34 p.m. UTC

Comments

Arun Isaac Nov. 23, 2020, 6:22 p.m. UTC | #1
Thanks, pushed to master!
diff mbox series

Patch

From 469b01aea4c9dc1cd4212ba2e362c6180709c1ee Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Sun, 22 Nov 2020 14:31:11 +0100
Subject: [PATCH] gnu: Add emacs-orderless.

* gnu/packages/emacs-xyz.scm (emacs-orderless): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 885487bf17..869819f8a8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6770,6 +6770,30 @@  marginal benefit compared to the additional complexity of a new
 interface.")
     (license license:expat)))
 
+(define-public emacs-orderless
+  (package
+    (name "emacs-orderless")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/oantolin/orderless")
+             (commit version)))
+       (sha256
+        (base32 "032lfwflkpaxbcxl4jf438vapswsdagipjczcn30sc4dfdh3p42c"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/oantolin/orderless")
+    (synopsis "Emacs completion style that matches multiple regexps in any order")
+    (description
+     "This package provides an orderless completion style that divides the
+pattern into space-separated components, and matches candidates that match all
+of the components in any order.  Each component can match in any one of several
+ways: literally, as a regexp, as an initialism, in the flex style, or as
+multiple word prefixes.")
+    (license license:gpl3+)))
+
 (define-public emacs-smartparens
   (package
     (name "emacs-smartparens")
-- 
2.28.0