diff mbox series

[bug#47965] gnu: Add emacs-nameless

Message ID 875z0def5w.fsf@posteo.net
State Accepted
Headers show
Series [bug#47965] gnu: Add emacs-nameless | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev April 23, 2021, 5:35 a.m. UTC

Comments

Nicolas Goaziou April 23, 2021, 9:17 a.m. UTC | #1
Hello,

Alexandr Vityazev <avityazev@posteo.org> writes:

> Subject: [PATCH] gnu: Add emacs-nameless.

Thank you.

I fixed the commit message: it was not including the name of the file
being modified.  See commit log for details.

> +    (home-page
> +     "https://github.com/Malabarba/nameless")
> +    (synopsis
> +     "Hide package namespace in your emacs-lisp code")

Line breaks are not necessary above.

> +    (description
> +     "This package provides a @code{nameless-mode} minor mode
> +in which the package namespace prefix is ​​hidden by a colon (@code{:}).
> +
> +To use this package add the following configuration to your Emacs
> +init file: @code{(add-hook 'emacs-lisp-mode-hook #'nameless-mode)}.
> +
> +You can configure a string to use instead of @code{:} by setting the
> +@code{nameless-prefix}, and the name of the face used is `nameless-face'.
> +While the mode is active, the @key{C-c C--} key inserts the package
> +namespace if appropriate.")

I removed some parts of the description, when I felt they belonged to
a manual instead.

> +    (license license:gpl2+)))

Note upstream license is odd. There is a GPL2 LICENSE file, but the
library is licensed gpl3+. I think gpl2+ is fine, but stil…

Applied.

Regards,
diff mbox series

Patch

From cbfba4d515fb27c304ec92da0641bf1947ddaf67 Mon Sep 17 00:00:00 2001
From: Alexandr Vityazev <avityazev@posteo.org>
Date: Fri, 23 Apr 2021 00:17:18 +0300
Subject: [PATCH] gnu: Add emacs-nameless.

---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5214ad3852..95a3222123 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27692,3 +27692,35 @@  shorter than usual, using mostly unprefixed keys.")
 vc root directory, and for displaying and/or sorting by the vc
 status of listed files.")
     (license license:gpl3+)))
+
+(define-public emacs-nameless
+  (package
+    (name "emacs-nameless")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Malabarba/Nameless")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "107q1rximjnag9r9vgwh0iv687i3rsscbdnjc46f8l16j6vi4n7d"))))
+    (build-system emacs-build-system)
+    (home-page
+     "https://github.com/Malabarba/nameless")
+    (synopsis
+     "Hide package namespace in your emacs-lisp code")
+    (description
+     "This package provides a @code{nameless-mode} minor mode
+in which the package namespace prefix is ​​hidden by a colon (@code{:}).
+
+To use this package add the following configuration to your Emacs
+init file: @code{(add-hook 'emacs-lisp-mode-hook #'nameless-mode)}.
+
+You can configure a string to use instead of @code{:} by setting the
+@code{nameless-prefix}, and the name of the face used is `nameless-face'.
+While the mode is active, the @key{C-c C--} key inserts the package
+namespace if appropriate.")
+    (license license:gpl2+)))
-- 
2.31.1