diff mbox series

[bug#50003] gnu: Add emacs-pcmpl-args.

Message ID 875ywc6xkh.fsf@trop.in
State Accepted
Headers show
Series [bug#50003] gnu: Add emacs-pcmpl-args. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin Aug. 11, 2021, 9:33 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pcmpl-args): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Aug. 18, 2021, 5:08 p.m. UTC | #1
Hello,

Andrew Tropin <andrew@trop.in> writes:

> * gnu/packages/emacs-xyz.scm (emacs-pcmpl-args): New variable.

Applied (at a different location in the "emacs-xyz.scm" file).

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 172d620adc..2c71875baf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29183,3 +29183,25 @@  current region or entire buffer.")
 It includes syntax highlighting, automatic indentation, and imenu integration.
 Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
     (license license:unlicense)))
+
+(define-public emacs-pcmpl-args
+  (package
+    (name "emacs-pcmpl-args")
+    (version "0.1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JonWaltman/pcmpl-args.el")
+             (commit version)))
+       (sha256
+        (base32 "19xwwpfcf0l9jh7xixyjd5adivj27jw00zvxb7n1240k5p332pzi"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/JonWaltman/pcmpl-args.el")
+    (synopsis "Enhanced shell command completion")
+    (description "The pcmpl-args package extends option and argument
+completion of shell commands read by Emacs.  It is intended to make shell
+completion in Emacs comparable to the rather excellent completion provided by
+both Bash and Zsh.")
+    (license license:gpl3+)))