diff mbox series

[bug#50876] gnu: ocaml-ctypes: Update to 0.19.1.

Message ID 875yuk33w7.fsf@yoctocell.xyz
State Accepted
Headers show
Series [bug#50876] gnu: ocaml-ctypes: Update to 0.19.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Sept. 28, 2021, 7:18 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ctypes): Update to 0.19.1.
[arguments]<#:tests?>: Enable.
<#phases>{make-writable}: Simplify.
[inputs]: Remove ocaml-topkg and opam.  Move ocaml-ounit and ocaml-lwt to ...
[native-inputs]: ... here.
---
 gnu/packages/ocaml.scm | 25 +++++++++----------------
 1 file changed, 9 insertions(+), 16 deletions(-)


base-commit: 8c6c33a2a5bf385e1589b405ee7f842684ed80c1

Comments

Julien Lepiller Oct. 8, 2021, 2:46 a.m. UTC | #1
Pushed to master as a0804f44456ee49e4c50130df0daf32aaf8f5281, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e30bd2f613..6577a38167 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4012,7 +4012,7 @@  (define-public ocaml-integers
 (define-public ocaml-ctypes
   (package
    (name "ocaml-ctypes")
-   (version "0.18.0")
+   (version "0.19.1")
    (home-page "https://github.com/ocamllabs/ocaml-ctypes")
    (source (origin
              (method git-fetch)
@@ -4022,34 +4022,27 @@  (define-public ocaml-ctypes
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "03zrbnl16m67ls0yfhq7a4k4238x6x6b3m456g4dw2yqwc153vks"))))
+               "1xi1a486gssrb23zln3sf7zn0rmyl1k684bdf9iqkhgpz607fq6s"))))
    (build-system ocaml-build-system)
    (arguments
-    `(#:tests? #f; require an old lwt
-      #:make-flags
+    `(#:make-flags
       (list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'make-writable
           (lambda _
-            (for-each
-              (lambda (file)
-                (let ((stat (stat file)))
-                  (chmod file (+ #o200 (stat:mode stat)))))
-              (find-files "." "."))
-            #t))
+            (for-each make-file-writable
+                      (find-files "."))))
         (delete 'configure))))
    (native-inputs
-    `(("pkg-config" ,pkg-config)))
+    `(("pkg-config" ,pkg-config)
+      ("ounit" ,ocaml-ounit)
+      ("lwt" ,ocaml-lwt)))
    (propagated-inputs
     `(("bigarray-compat" ,ocaml-bigarray-compat)
       ("integers" ,ocaml-integers)))
    (inputs
-    `(("libffi" ,libffi)
-      ("ounit" ,ocaml-ounit)
-      ("lwt" ,ocaml-lwt)
-      ("topkg" ,ocaml-topkg)
-      ("opam" ,opam)))
+    `(("libffi" ,libffi)))
    (synopsis "Library for binding to C libraries using pure OCaml")
    (description "Ctypes is a library for binding to C libraries using pure
 OCaml.  The primary aim is to make writing C extensions as straightforward as