diff mbox series

[bug#55929] gnu: maven: Add maven-doxia-sink-api

Message ID 875ykyvvc5.fsf@gmail.com
State Accepted
Headers show
Series [bug#55929] gnu: maven: Add maven-doxia-sink-api | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 18, 2022, 3:34 p.m. UTC
Hello.

> If the referenced pom file is not installed, it won't be found by Maven
> later when we use it to run the maven-plugin-plugin. See for instance
> how the parent pom is installed in java-slf4j-parent, and propagated
> from java-slf4j-api (and recursively from java-slf4j-simple).

> This top-level pom also has the following, so it should propagate it:

> <parent>
>  <groupId>org.apache.maven</groupId>
>  <artifactId>maven-parent</artifactId>
>  <version>34</version>
>  <relativePath />
> </parent>

> We already have it: maven-parent-pom-34.

Done.  Please see the patch, I'm hoping it should be OK by now.
- Artyom

Comments

Julien Lepiller June 18, 2022, 4:52 p.m. UTC | #1
On June 18, 2022 5:34:50 PM GMT+02:00, "Artyom V. Poptsov" <poptsov.artyom@gmail.com> wrote:
>Hello.
>
>> If the referenced pom file is not installed, it won't be found by Maven
>> later when we use it to run the maven-plugin-plugin. See for instance
>> how the parent pom is installed in java-slf4j-parent, and propagated
>> from java-slf4j-api (and recursively from java-slf4j-simple).
>
>> This top-level pom also has the following, so it should propagate it:
>
>> <parent>
>>  <groupId>org.apache.maven</groupId>
>>  <artifactId>maven-parent</artifactId>
>>  <version>34</version>
>>  <relativePath />
>> </parent>
>
>> We already have it: maven-parent-pom-34.
>
>Done.  Please see the patch, I'm hoping it should be OK by now.
>

Hi,

I think you sent the same patch as previously?
diff mbox series

Patch

From b4020bc283f18d7b7394976c4288d04130f1e651 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 12 Jun 2022 21:42:33 +0300
Subject: [PATCH] gnu: maven: Add maven-doxia-sink-api

* gnu/packages/maven.scm (maven-doxia-sink-api): New variable.
---
 gnu/packages/maven.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 817fee1c71..93c1538bae 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3887,3 +3888,31 @@  reports in two different file formats, plain text and xml.")))
     (description "This plugin provides the capability to build jars.  If you
 would like to sign jars please use the Maven Jarsigner Plugin instead.")
     (license license:asl2.0)))
+
+(define-public maven-doxia-sink-api
+  (package
+    (name "maven-doxia-sink-api")
+    (version "2.0.0-M2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitbox.apache.org/repos/asf/maven-doxia.git")
+                    (commit (string-append "doxia-" version))))
+              (file-name (git-file-name "doxia" version))
+              (sha256
+               (base32
+                "0jx96lg0hgjsrm8mynhac4hwh2hmgiwjpwpx2k03yr14040zcr48"))))
+    (build-system ant-build-system)
+    (native-inputs
+     (list java-javax-inject))
+    (arguments
+     (list #:jar-name "doxia-core.jar"
+           #:source-dir "doxia-sink-api/src/main/java"
+           #:tests? #f))                ; no tests
+    (home-page "https://maven.apache.org/doxia/index.html")
+    (synopsis "Generic markup language interface")
+    (description "The @code{Sink} interface is a generic markup language
+interface provided as a Java API. It contains several methods that encapsulate
+common text syntax. A start tag is denoted by @code{xxxx()} method and a end
+of tag by @code{xxxx_()} method.")
+    (license license:asl2.0)))
-- 
2.25.1