diff mbox series

[bug#57171] gnu: Add emacs-pdfgrep.

Message ID 875yiwtkgj.fsf@gmail.com
State Accepted
Headers show
Series [bug#57171] gnu: Add emacs-pdfgrep. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

pinoaffe Aug. 13, 2022, 12:08 p.m. UTC
Date: Sat, 13 Aug 2022 13:59:20 +0200
From ed9c9546ff4ed6f24dd534fc80854755f20d8de1 Mon Sep 17 00:00:00 2001
* gnu/packages/emacs-xyz.scm (emacs-pdfgrep): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus Aug. 23, 2022, 10:07 a.m. UTC | #1
Thanks for the patch.

I’d change the let* to let, because we don’t need previous bindings to
be available in later bindings.

It would also be nice to avoid propagating pdfgrep.
We could probably avoid propagation by patching
https://github.com/jeremy-compostella/pdfgrep/blob/master/pdfgrep.el#L59
and perhaps also line 81 (executable-find "pdfgrep").

In the synopsis I’d remove the `…' quotes, but that’s a nit-pick.

What do you think?
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c1d322db3..18e32a3283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,7 +70,7 @@ 
 ;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
 ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
+;;; Copyright © 2020, 2022 pinoaffe <pinoaffe@gmail.com>
 ;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
 ;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -3839,6 +3839,28 @@  (define-public emacs-saveplace-pdf-view
 restore the saved place.")
     (license license:gpl3+)))
 
+(define-public emacs-pdfgrep
+  (let* ((commit "a4ca0a1e6521de93f28bb6736a5344b4974d144c")
+         (revision "0"))
+    (package
+      (name "emacs-pdfgrep")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jeremy-compostella/pdfgrep.git")
+               (commit commit)))
+         (sha256
+          (base32 "093sm3ywa338lhhz2ib3ylcgklsbxcsqck2qsaq26i2qxr0r7lq2"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list pdfgrep))
+      (home-page "https://github.com/jeremy-compostella/pdfgrep")
+      (synopsis "Run `pdfgrep' within Emacs and display the results.")
+      (description
+       "This package provides the Emacs \"grep\" facilities for the pdfgrep program.")
+      (license license:gpl3+))))
+
 (define-public emacs-dash
   (package
     (name "emacs-dash")