diff mbox series

[bug#50847] gnu: Add ydotool.

Message ID 875yhamw8o.fsf@ngraves.fr
State Accepted
Headers show
Series [bug#50847] gnu: Add ydotool. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 26, 2022, 7:27 a.m. UTC
* gnu/packages/xdisorg.scm (ydotool): New variable.
---
 gnu/packages/xdisorg.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

--
2.37.3

--
Best regards,
Nicolas Graves

Comments

Nicolas Graves Sept. 26, 2022, 8:12 a.m. UTC | #1
Hi!

I sent this updated patch because the package is much more simple since
the version 1.0.0. Tested and it builds.
Andrew Tropin Oct. 13, 2022, 7:08 a.m. UTC | #2
On 2022-09-26 10:12, Nicolas Graves via Guix-patches via wrote:

> Hi!
>
> I sent this updated patch because the package is much more simple since
> the version 1.0.0. Tested and it builds. 

Hi Nicolas!

Thank you very much for the patch, applied, added the comment about no
tests, pushed.

Coulde you ask the upstream to add a udev rules file to the repo and
make a new release, please?  So we can have it in resulting package in
/lib/udev/rules.d/ (as it done in pipewire, brightnessctl, lvm2, fuse
for example) and can pass the package to udev service.

Hi Alexandr!

Thank you for your work, I close the issue as it's done, but if you want
other packages from this thread to be reviewed and merged as well,
please resubmit the updated patches to a new thread.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9908f29191..575c95ff2a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3163,3 +3163,24 @@  (define-public wlsunset
 light filter or night light.")
     (license license:expat)))

+(define-public ydotool
+  (package
+    (name "ydotool")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ReimuNotMoe/ydotool")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h19dh7kai0iikssr7sq0wfkh0sb18dylyfg7c3dkwc158cdg9cr"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #f))
+    (native-inputs (list scdoc))
+    (home-page "https://github.com/ReimuNotMoe/ydotool")
+    (synopsis "Generic Linux command-line automation tool (no X!)")
+    (description "@code{ydotool} is a Linux command-line tool that simulates
+keyboard input, mouse actions, etc.  programmatically or manually.")
+    (license license:agpl3+)))