diff mbox series

[bug#60540] teams: Add scope for Embedded / Bootstrap

Message ID 875ydmalre.fsf@yucca
State New
Headers show
Series [bug#60540] teams: Add scope for Embedded / Bootstrap | expand

Commit Message

Vagrant Cascadian Jan. 4, 2023, 5:53 a.m. UTC
There are some packages that are obviously related to embedded
(e.g. u-boot from bootloaders.scm, arm-trusted-firmware from
firmware.scm) and bootstrapping (mes.scm).

Patch attached.

live well,
  vagrant

Comments

Mathieu Othacehe Jan. 8, 2023, 1:43 p.m. UTC | #1
Hello Vagrant,

>  (define-team embedded-bootstrap
>    (team 'embedded-bootstrap
> -        #:name "Embedded / Bootstrap"))
> +        #:name "Embedded / Bootstrap"
> +        #:scope (list "gnu/packages/bootloaders.scm"
> +                      "gnu/packages/firmware.scm"
> +                      "gnu/packages/mes.scm")))

Seems fine.

I think we could have two distinct teams here: embedded and
bootstrap. There are quite a few people, like me, following closely the
embedded part, but not so closely the bootstrap part.

WDYT?

Thanks,

Mathieu
Vagrant Cascadian Jan. 10, 2023, 11:21 p.m. UTC | #2
On 2023-01-08, Mathieu Othacehe wrote:
>>  (define-team embedded-bootstrap
>>    (team 'embedded-bootstrap
>> -        #:name "Embedded / Bootstrap"))
>> +        #:name "Embedded / Bootstrap"
>> +        #:scope (list "gnu/packages/bootloaders.scm"
>> +                      "gnu/packages/firmware.scm"
>> +                      "gnu/packages/mes.scm")))
>
> Seems fine.
>
> I think we could have two distinct teams here: embedded and
> bootstrap. There are quite a few people, like me, following closely the
> embedded part, but not so closely the bootstrap part.

Yeah, I think they should be split so started a thread on guix-devel:

  https://lists.gnu.org/archive/html/guix-devel/2023-01/msg00048.html

But I also wanted to start by keeping this patch simple. Although it
could really use a description too ...

live well,
  vagrant
diff mbox series

Patch

From 6c8076261cf1a93134e3435124d4a7e9dcbbba1c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 3 Jan 2023 21:41:34 -0800
Subject: [PATCH 3/4] teams: Add scope for Embedded / Bootstrap team.

* etc/teams.scm.in (embedded-bootstrap): Add bootloaders, firmware and mes to
  scope.
---
 etc/teams.scm.in | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index b3a1c72c28..921c101aa7 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -244,7 +244,10 @@  asdf-build-system."
 
 (define-team embedded-bootstrap
   (team 'embedded-bootstrap
-        #:name "Embedded / Bootstrap"))
+        #:name "Embedded / Bootstrap"
+        #:scope (list "gnu/packages/bootloaders.scm"
+                      "gnu/packages/firmware.scm"
+                      "gnu/packages/mes.scm")))
 
 (define-team rust
   (team 'rust
-- 
2.30.2