diff mbox series

[bug#61222,1/2] gnu: Add go-1.20.

Message ID 875yck9166.wl-hako@ultrarare.space
State New
Headers show
Series gnu: Add go-1.20. | expand

Commit Message

Hilton Chain Feb. 2, 2023, 3:49 a.m. UTC
* gnu/packages/golang.scm (go-1.20): New variable.
---
 gnu/packages/golang.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 93df6cb061..2d5d1dca43 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -889,6 +889,25 @@  (define-public go-1.19
                           '("CONTRIBUTING.md" "PATENTS" "README.md"
                             "SECURITY.md"))))))))))
 
+(define-public go-1.20
+  (package
+    (inherit go-1.19)
+    (name "go")
+    (version "1.20")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/golang/go")
+                    (commit (string-append "go" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0a7wjzv14kaqg5l7ambv5zj4rj7sgah9yhcg6k6da6ygm6bs4dv3"))))
+    (native-inputs
+     ;; Go 1.20 and later requires Go 1.17 as the bootstrap toolchain.
+     ;; See `src/cmd/dist/notgo117.go`.
+     (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+
 (define-public go go-1.17)
 
 (define make-go-std