diff mbox series

[bug#61889] gnu: Add mairix.

Message ID 875yb8kwwl.fsf@martinmarshall.com
State New
Headers show
Series [bug#61889] gnu: Add mairix. | expand

Commit Message

Martin Marshall March 10, 2023, 11:29 p.m. UTC
Per Guix QA, all builds succeed except for "i586-gnu".  Still not sure
why my system fails the check phase when emulating "armhf-linux".  Will
attribute to user-error.

Attached is an updated patch which builds successfully on my
x86_64-linux system.

Changes from the original patch:
* Moved propagated-inputs to inputs.
* Added perl to inputs.
* Removed (setenv "LC_ALL" "en_US.UTF-8") from configure phase.
* Added (supported-systems ...) at the end to reflect the systems
indicated by Guix QA as building correctly.

Best regards.

Comments

Nicolas Goaziou April 2, 2023, 9:16 p.m. UTC | #1
Hello,

Martin Marshall <law@martinmarshall.com> writes:

> Attached is an updated patch which builds successfully on my
> x86_64-linux system.

Applied. Thank you.
>

> * Added (supported-systems ...) at the end to reflect the systems
> indicated by Guix QA as building correctly.

I removed the supported-systems field since it is not strictly necessary here.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6ef4c6fdab..95dee43df0 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -408,6 +408,46 @@  (define-public mailutils
      ;; Libraries are under LGPLv3+, and programs under GPLv3+.
      (list license:gpl3+ license:lgpl3+))))
 
+(define-public mairix
+  (let ((commit "1cc06f4a73ba4b940008c1ffc398d2ac708cd6d6")
+        (revision "0"))
+    (package
+      (name "mairix")
+      (version (git-version "0.24" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/vandry/mairix")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "12bhmk5j77cl3vjda48cmdysq1c2yjzvfv6zm4hlky6d5g3l49d7"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:parallel-tests? #f
+             #:phases #~(modify-phases %standard-phases
+                          (replace 'configure
+                            (lambda* (#:key inputs #:allow-other-keys)
+                              (invoke "./configure"
+                                      (string-append "--prefix="
+                                                     #$output)))))))
+      (inputs (list bzip2
+                    openssl
+                    perl
+                    xz
+                    zlib))
+      (native-inputs (list bison
+                           flex))
+      (home-page "https://github.com/vandry/mairix")
+      (synopsis "Program for indexing and searching email messages")
+      (description
+       "Mairix is a program for indexing and searching email messages stored in
+Maildir, MH, MMDF or mbox folders.")
+      (license license:gpl2)
+      (supported-systems (list "x86_64-linux" "i686-linux" "aarch64-linux"
+                               "armhf-linux" "powerpc64le-linux")))))
+
 (define-public go-gitlab.com-shackra-goimapnotify
   (package
     (name "go-gitlab.com-shackra-goimapnotify")