diff mbox series

[bug#66378] gnu: Add rust-hyprland-0.3.

Message ID 875y3jpafo.fsf@gmail.com
State New
Headers show
Series [bug#66378] gnu: Add rust-hyprland-0.3. | expand

Commit Message

Aleksandr Vityazev Oct. 7, 2023, 12:01 a.m. UTC
* gnu/packages/crates-io.scm (rust-hyprland-0.3): New variable.
---
 gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)


base-commit: a7e6b4c98b97921ab695218f9b89be4f1ded48c9
prerequisite-patch-id: ec4a09723b91089c8eb5b5269ae81272bb4d81b4
prerequisite-patch-id: 9680399593e3dcdb5b10ee646023efd1215942d9
prerequisite-patch-id: 66497a0079d0077e7b5001707d8211c525ea7193
prerequisite-patch-id: 4f512542ae5806d47054e063e3dd1df66258c530
prerequisite-patch-id: 48abb1e84ca8d85b23794222f8fa5b4d2dfa4699
prerequisite-patch-id: a7fdd2f87131ad73865389152d4a826df24fcae7
prerequisite-patch-id: 1600413a45a50114906f4390653c3fbb7f536a4c
prerequisite-patch-id: 51e95882782a53eda933e884fb5e80487ba52b9f
prerequisite-patch-id: 177b2873f4e77585c464ac3d24bec78d58f128bd
prerequisite-patch-id: 631a6785018f999fcbf7e22fb8e2aae9329ced55
prerequisite-patch-id: 1bd1b328f9e3c7119fed731ffd7e7d87ac33f0c2
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f0cc7a31b0..9222a0bc2a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31227,6 +31227,46 @@  (define-public rust-hyphenation-0.8
      "This package provides a Knuth-Liang hyphenation for a variety of languages.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-hyprland-0.3
+  (package
+    (name "rust-hyprland")
+    (version "0.3.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hyprland" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "01pvz7bpdwj6ja410mm2flrk43x6cq1xbp11mpf1ngwzi7klmafz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-async-net" ,rust-async-net-1)
+        ("rust-async-std" ,rust-async-std-1)
+        ("rust-async-trait" ,rust-async-trait-0.1)
+        ("rust-derive-more" ,rust-derive-more-0.99)
+        ("rust-doc-comment" ,rust-doc-comment-0.3)
+        ("rust-futures" ,rust-futures-0.3)
+        ("rust-futures-lite" ,rust-futures-lite-1)
+        ("rust-hex" ,rust-hex-0.4)
+        ("rust-hyprland-macros" ,rust-hyprland-macros-0.3)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-num-traits" ,rust-num-traits-0.2)
+        ("rust-paste" ,rust-paste-1)
+        ("rust-regex" ,rust-regex-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-serde-repr" ,rust-serde-repr-0.1)
+        ("rust-strum" ,rust-strum-0.25)
+        ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/hyprland-community/hyprland-rs")
+    (synopsis "An unofficial rust wrapper for Hyprland's IPC")
+    (description
+     "This package provides a unoffical rust wrapper for hyprland's IPC.")
+    (license license:gpl3+)))
+
 (define-public rust-hyprland-macros-0.3
   (package
     (name "rust-hyprland-macros")