diff mbox series

[bug#68424,1/3] gnu: hypercorn: Add missing propagated-inputs.

Message ID 875xzx4f87.fsf@troyfigiel.com
State New
Headers show
Series Fix python-hypercorn | expand

Commit Message

Troy Figiel Jan. 13, 2024, 11:26 a.m. UTC
* gnu/packages/python-web.scm (hypercorn)[propagated-inputs]: Add
python-exceptiongroup and python-tomli. Remove python-toml and python-typing-extensions.
---
 gnu/packages/python-web.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 567b01f396..dd85581032 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2392,11 +2392,11 @@  (define-public hypercorn
     (build-system pyproject-build-system)
     ;; Propagate because Hypercorn also exposes functionality over a module.
     (propagated-inputs
-     (list python-h11
+     (list python-exceptiongroup
+           python-h11
            python-h2
            python-priority
-           python-toml
-           python-typing-extensions
+           python-tomli
            python-wsproto))
     (native-inputs
      (list python-hypothesis