[bug#75381] gnu: pcb2gcode: Update to pre-release.
Commit Message
From a3d86f0c6e89116b6a4840c69ff1ba2b6290e93c Mon Sep 17 00:00:00 2001
Message-ID: <a3d86f0c6e89116b6a4840c69ff1ba2b6290e93c.1736073815.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Sun, 5 Jan 2025 13:35:51 +0300
Subject: [PATCH] gnu: pcb2gcode: Update to pre-release.
* gnu/packages/engineering.scm (pcb2gcode): Update to pre-release, change
indentation, run guix style.
[version]: Use git-version.
[source]: Use specific commit, do not recurse submodules (there are none).
Change-Id: I97c5b6521c86606c572ce67efc60b13351b1b4cd
---
gnu/packages/engineering.scm | 55 ++++++++++++++++++------------------
1 file changed, 27 insertions(+), 28 deletions(-)
@@ -3489,37 +3489,36 @@ (define-public emacs-poke
(deprecated-package "emacs-poke" poke))
(define-public pcb2gcode
- (package
- (name "pcb2gcode")
- (version "2.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pcb2gcode/pcb2gcode")
- (commit (string-append "v" version))
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "01s41znkcq9x1rinsdqrrdj8p35isckrcxs14ajsi7wr39n1m5kk"))))
- (build-system gnu-build-system)
- (inputs
- (list boost
- geos
- gerbv
- glibmm
- gtkmm-2
- (librsvg-for-system)))
- (native-inputs
- (list autoconf automake libtool pkg-config))
- (home-page "https://github.com/pcb2gcode/pcb2gcode")
- (synopsis "Generate G-code for milling PCBs")
- (description "pcb2gcode is a command-line program for isolation routing
+ (let ((commit "8c084afd00c6653dfa9cbf24a1dbeeb24f592aa9")
+ (revision "0"))
+ (package
+ (name "pcb2gcode")
+ (version (git-version "2.5.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pcb2gcode/pcb2gcode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19hyzd1601l51bwlv43j8l602nfacbjwqf54m5xsmj50718bcks2"))))
+ (build-system gnu-build-system)
+ (inputs (list boost
+ geos
+ gerbv
+ glibmm
+ gtkmm-2
+ (librsvg-for-system)))
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (home-page "https://github.com/pcb2gcode/pcb2gcode")
+ (synopsis "Generate G-code for milling PCBs")
+ (description
+ "pcb2gcode is a command-line program for isolation routing
and drilling of PCBs. It takes Gerber files as input and outputs G-code files
for the milling of PCBs. It also includes an autoleveller for the automatic
dynamic calibration of the milling depth.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
;; libdxfrw has no readme, no version release, no tags. Initial commit says
;; "libdxfrw-0.6.3 import", but it shares no git history with "upstream"
base-commit: e383e8e34097b064d4baa4207673c6ba30617347
--
2.47.1