diff mbox series

[bug#37411] gnu: Add fennel.

Message ID 874l13ztat.fsf@librem.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#37411] gnu: Add fennel. | expand

Commit Message

Alex ter Weele Sept. 23, 2019, 1:37 a.m. UTC
fennel 0.3.0 just released. Below is an updated patch. The new release
includes FENNEL_PATH, which is now populated by the package
definition, so (require "fennelview") now works, addressing a
shortcoming of the previous patch. The new release also includes
completion via readline, which is not supported in this package
definition. For that reason, I would consider this patch WIP.

Comments

宋文武 Sept. 24, 2019, 11:34 a.m. UTC | #1
Alex ter Weele <alex.ter.weele@gmail.com> writes:

> fennel 0.3.0 just released. Below is an updated patch. The new release
> includes FENNEL_PATH, which is now populated by the package
> definition, so (require "fennelview") now works, addressing a
> shortcoming of the previous patch. The new release also includes
> completion via readline, which is not supported in this package
> definition. For that reason, I would consider this patch WIP.
>

We can also add a comment for the lack of readline, and go ahead :-)


>>From 5156cfff4e0e9c8b7223213ab28c891c97641e6c Mon Sep 17 00:00:00 2001
> From: Alex ter Weele <alex.ter.weele@gmail.com>
> Date: Sat, 7 Sep 2019 16:18:38 -0500
> Subject: [PATCH] gnu: Add fennel.
>
> * gnu/packages/fennel.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add fennel.scm.
> ---
>  gnu/local.mk            |  1 +
>  gnu/packages/fennel.scm | 63 +++++++++++++++++++++++++++++++++++++++++
>  2 files changed, 64 insertions(+)
>  create mode 100644 gnu/packages/fennel.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index b7a5ef825b..84bfc8df2c 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -176,6 +176,7 @@ GNU_SYSTEM_MODULES =				\
>    %D%/packages/erlang.scm			\
>    %D%/packages/fabric-management.scm		\
>    %D%/packages/fcitx.scm			\
> +  %D%/packages/fennel.scm			\
>    %D%/packages/figlet.scm			\
>    %D%/packages/file.scm				\
>    %D%/packages/file-systems.scm			\
> diff --git a/gnu/packages/fennel.scm b/gnu/packages/fennel.scm
> new file mode 100644
> index 0000000000..0bce77fa66
> --- /dev/null
> +++ b/gnu/packages/fennel.scm
> @@ -0,0 +1,63 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2019 Alex ter Weele <alex.ter.weele@gmail.com>
> +
> +(define-module (gnu packages fennel)
> +  #:use-module (gnu packages lua)
> +  #:use-module (guix packages)
> +  #:use-module (guix build-system gnu)
> +  #:use-module (guix git-download)
> +  #:use-module ((guix licenses) #:prefix license:))
> +
> +(define-public fennel
> +  (package
> +    (name "fennel")
> +    (version "0.3.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bakpakin/Fennel.git")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1d5kzgb9l2gdya1jqvp4ni03rd8v270fbhy5wxkjbhr9xf2xb14k"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:test-target "test"
> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure)
> +         (delete 'build)
> +         (replace 'install
> +           (lambda _
> +             (let* ((out (assoc-ref %outputs "out"))
> +                    (data (string-append out "/share/"))
> +                    (bin (string-append out "/bin/")))
> +               (copy-recursively (assoc-ref %build-inputs "source") data)
> +               (install-file "fennel" bin)
> +               (wrap-program (string-append bin "fennel")
> +                 `("LUA_PATH" ";" prefix (,(string-append data "?.lua")))
> +                 `("FENNEL_PATH" ";" prefix (,(string-append data "?.fnl"))))))))))

Look at its source code, I think it should be installed like this:

  fennel             -> ${out}/bin/fennel
  fennel.1           -> ${out}/share/man/man1/fennel.1
  fennel.lua         -> ${out}/share/lua/${lua-version}/fennel.lua
  fennelview.fnl     -> ${out}/share/fennel/fennelview.fnl

We may also pick some md files into ${out}/share/doc/fennel, and drop
other files...  What do you think?

> +    (inputs
> +     `(("lua" ,lua)))
> +    (home-page "https://fennel-lang.org/")
> +    (synopsis "Lua lisp language")
> +    (description "Fennel is a programming language that brings together the
> +speed, simplicity, and reach of Lua with the flexibility of a lisp syntax and
> +macro system.
> +
> +    * Full Lua compatibility: Easily call any Lua function or library from
> +Fennel and vice-versa.
> +
> +    * Zero overhead: Compiled code should be just as or more efficient than
> +hand-written Lua.
> +
> +    * Compile-time macros: Ship compiled code with no runtime dependency on
> +Fennel.
> +
> +    * Embeddable: Fennel is a one-file library as well as an executable.
> +Embed it in other programs to support runtime extensibility and interactive
> +development.
> +
> +Anywhere you can run Lua code, you can run Fennel code.")
> +    (license license:x11)))

I think its license should be 'expat', 'x11' has an extra paragraph
talking about "X Consortium":

<https://directory.fsf.org/wiki/License:X11>
<https://directory.fsf.org/wiki/License:Expat>

Otherwise, look good to me, thank you!
Ludovic Courtès Oct. 1, 2019, 9:17 p.m. UTC | #2
Hi Alex,

Alex ter Weele <alex.ter.weele@gmail.com> skribis:

>>From 5156cfff4e0e9c8b7223213ab28c891c97641e6c Mon Sep 17 00:00:00 2001
> From: Alex ter Weele <alex.ter.weele@gmail.com>
> Date: Sat, 7 Sep 2019 16:18:38 -0500
> Subject: [PATCH] gnu: Add fennel.
>
> * gnu/packages/fennel.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add fennel.scm.

Some comments to complement what 宋文武 wrote earlier.

> +++ b/gnu/packages/fennel.scm
> @@ -0,0 +1,63 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2019 Alex ter Weele <alex.ter.weele@gmail.com>
> +

Please add a complete header as in the other files.

> +         (replace 'install
> +           (lambda _
> +             (let* ((out (assoc-ref %outputs "out"))
> +                    (data (string-append out "/share/"))
> +                    (bin (string-append out "/bin/")))
> +               (copy-recursively (assoc-ref %build-inputs "source") data)
> +               (install-file "fennel" bin)
> +               (wrap-program (string-append bin "fennel")
> +                 `("LUA_PATH" ";" prefix (,(string-append data "?.lua")))
> +                 `("FENNEL_PATH" ";" prefix (,(string-append data "?.fnl"))))))))))

Could you add #t at the end of the phase?

> +    (home-page "https://fennel-lang.org/")
> +    (synopsis "Lua lisp language")

Maybe “Lisp-like programming language embedded in Lua”?

> +    (description "Fennel is a programming language that brings together the
> +speed, simplicity, and reach of Lua with the flexibility of a lisp syntax and
> +macro system.
> +
> +    * Full Lua compatibility: Easily call any Lua function or library from
> +Fennel and vice-versa.
> +
> +    * Zero overhead: Compiled code should be just as or more efficient than
> +hand-written Lua.
> +
> +    * Compile-time macros: Ship compiled code with no runtime dependency on
> +Fennel.
> +
> +    * Embeddable: Fennel is a one-file library as well as an executable.
> +Embed it in other programs to support runtime extensibility and interactive
> +development.
> +
> +Anywhere you can run Lua code, you can run Fennel code.")

Please use @itemize and @item for the bullet list.

Could you send an updated patch?

Thanks!

Ludo’.
Ludovic Courtès Nov. 19, 2019, 9:39 a.m. UTC | #3
Hi Alex,

Did you have a chance to look into it?

(See <https://issues.guix.gnu.org/issue/37411>.)

Thanks in advance,
Ludo’.

Ludovic Courtès <ludo@gnu.org> skribis:

> Hi Alex,
>
> Alex ter Weele <alex.ter.weele@gmail.com> skribis:
>
>>>>From 5156cfff4e0e9c8b7223213ab28c891c97641e6c Mon Sep 17 00:00:00 2001
>> From: Alex ter Weele <alex.ter.weele@gmail.com>
>> Date: Sat, 7 Sep 2019 16:18:38 -0500
>> Subject: [PATCH] gnu: Add fennel.
>>
>> * gnu/packages/fennel.scm: New file.
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Add fennel.scm.
>
> Some comments to complement what 宋文武 wrote earlier.
>
>> +++ b/gnu/packages/fennel.scm
>> @@ -0,0 +1,63 @@
>> +;;; GNU Guix --- Functional package management for GNU
>> +;;; Copyright © 2019 Alex ter Weele <alex.ter.weele@gmail.com>
>> +
>
> Please add a complete header as in the other files.
>
>> +         (replace 'install
>> +           (lambda _
>> +             (let* ((out (assoc-ref %outputs "out"))
>> +                    (data (string-append out "/share/"))
>> +                    (bin (string-append out "/bin/")))
>> +               (copy-recursively (assoc-ref %build-inputs "source") data)
>> +               (install-file "fennel" bin)
>> +               (wrap-program (string-append bin "fennel")
>> +                 `("LUA_PATH" ";" prefix (,(string-append data "?.lua")))
>> +                 `("FENNEL_PATH" ";" prefix (,(string-append data "?.fnl"))))))))))
>
> Could you add #t at the end of the phase?
>
>> +    (home-page "https://fennel-lang.org/")
>> +    (synopsis "Lua lisp language")
>
> Maybe “Lisp-like programming language embedded in Lua”?
>
>> +    (description "Fennel is a programming language that brings together the
>> +speed, simplicity, and reach of Lua with the flexibility of a lisp syntax and
>> +macro system.
>> +
>> +    * Full Lua compatibility: Easily call any Lua function or library from
>> +Fennel and vice-versa.
>> +
>> +    * Zero overhead: Compiled code should be just as or more efficient than
>> +hand-written Lua.
>> +
>> +    * Compile-time macros: Ship compiled code with no runtime dependency on
>> +Fennel.
>> +
>> +    * Embeddable: Fennel is a one-file library as well as an executable.
>> +Embed it in other programs to support runtime extensibility and interactive
>> +development.
>> +
>> +Anywhere you can run Lua code, you can run Fennel code.")
>
> Please use @itemize and @item for the bullet list.
>
> Could you send an updated patch?
>
> Thanks!
>
> Ludo’.
Alex ter Weele Nov. 19, 2019, 1:51 p.m. UTC | #4
Hi, sorry for the delay, I'm definitely able to make the changes, but
unfortunately I haven't gotten around to them.

Thanks to both of you for the review comments! I appreciate the eye for
detail :)
Jelle Licht May 28, 2023, 9:31 p.m. UTC | #5
Alex ter Weele <alex.ter.weele@gmail.com> writes:

> Hi, sorry for the delay, I'm definitely able to make the changes, but
> unfortunately I haven't gotten around to them.
>
> Thanks to both of you for the review comments! I appreciate the eye for
> detail :)

Closing, as fennel@1.3.0 has been available for a good while already.
- Jelle
diff mbox series

Patch

From 5156cfff4e0e9c8b7223213ab28c891c97641e6c Mon Sep 17 00:00:00 2001
From: Alex ter Weele <alex.ter.weele@gmail.com>
Date: Sat, 7 Sep 2019 16:18:38 -0500
Subject: [PATCH] gnu: Add fennel.

* gnu/packages/fennel.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add fennel.scm.
---
 gnu/local.mk            |  1 +
 gnu/packages/fennel.scm | 63 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 64 insertions(+)
 create mode 100644 gnu/packages/fennel.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index b7a5ef825b..84bfc8df2c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -176,6 +176,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/erlang.scm			\
   %D%/packages/fabric-management.scm		\
   %D%/packages/fcitx.scm			\
+  %D%/packages/fennel.scm			\
   %D%/packages/figlet.scm			\
   %D%/packages/file.scm				\
   %D%/packages/file-systems.scm			\
diff --git a/gnu/packages/fennel.scm b/gnu/packages/fennel.scm
new file mode 100644
index 0000000000..0bce77fa66
--- /dev/null
+++ b/gnu/packages/fennel.scm
@@ -0,0 +1,63 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Alex ter Weele <alex.ter.weele@gmail.com>
+
+(define-module (gnu packages fennel)
+  #:use-module (gnu packages lua)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:))
+
+(define-public fennel
+  (package
+    (name "fennel")
+    (version "0.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bakpakin/Fennel.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1d5kzgb9l2gdya1jqvp4ni03rd8v270fbhy5wxkjbhr9xf2xb14k"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda _
+             (let* ((out (assoc-ref %outputs "out"))
+                    (data (string-append out "/share/"))
+                    (bin (string-append out "/bin/")))
+               (copy-recursively (assoc-ref %build-inputs "source") data)
+               (install-file "fennel" bin)
+               (wrap-program (string-append bin "fennel")
+                 `("LUA_PATH" ";" prefix (,(string-append data "?.lua")))
+                 `("FENNEL_PATH" ";" prefix (,(string-append data "?.fnl"))))))))))
+    (inputs
+     `(("lua" ,lua)))
+    (home-page "https://fennel-lang.org/")
+    (synopsis "Lua lisp language")
+    (description "Fennel is a programming language that brings together the
+speed, simplicity, and reach of Lua with the flexibility of a lisp syntax and
+macro system.
+
+    * Full Lua compatibility: Easily call any Lua function or library from
+Fennel and vice-versa.
+
+    * Zero overhead: Compiled code should be just as or more efficient than
+hand-written Lua.
+
+    * Compile-time macros: Ship compiled code with no runtime dependency on
+Fennel.
+
+    * Embeddable: Fennel is a one-file library as well as an executable.
+Embed it in other programs to support runtime extensibility and interactive
+development.
+
+Anywhere you can run Lua code, you can run Fennel code.")
+    (license license:x11)))
-- 
2.23.0