diff mbox series

[bug#38842,2/3] gnu: Add liquid-dsp.

Message ID 874kxfhnez.fsf@gmail.com
State Accepted
Headers show
Series [bug#38842,1/3] gnu: rtl-sdr: Update to 0.6.0. | expand

Commit Message

Evan Straw Jan. 1, 2020, 3:21 a.m. UTC

Comments

Ricardo Wurmus Jan. 1, 2020, 10:06 p.m. UTC | #1
Hi Evan,

> From 71f377a45bfc830ff207cd56fa2d8fe0225a6874 Mon Sep 17 00:00:00 2001
> From: Evan Straw <evan.straw99@gmail.com>
> Date: Tue, 31 Dec 2019 15:31:58 -0800
> Subject: [PATCH 2/3] gnu: Add liquid-dsp.
>
> * gnu/packages/ham-radio.scm (liquid-dsp): New variable.

> +(define-public liquid-dsp
> +  (let ((commit "f11733208e3d0da928a0dc2111cdb2b0c4817cef")
> +        (revision "2")
> +        (version "1.3.2"))

Why this commit and not just the latest release 1.3.2?

> +      (description "liquid-dsp is a free and open-source digital signal
> +processing (DSP) library designed specifically for software-defined radios on
> +embedded platforms. The aim is to provide a lightweight DSP library that does
> +not rely on a myriad of external dependencies or proprietary and otherwise
> +cumbersome frameworks. All signal processing elements are designed to be
> +flexible, scalable, and dynamic, including filters, filter design,
> +oscillators, modems, synchronizers, complex mathematical operations, and much
> +more.")

Please remove “free and open-source” — all software in Guix is free
software, so we don’t need to state it.  Please also use double spacing
after each sentence.

--
Ricardo
Evan Straw Jan. 1, 2020, 10:27 p.m. UTC | #2
> Hi Evan,
>
>> From 71f377a45bfc830ff207cd56fa2d8fe0225a6874 Mon Sep 17 00:00:00 2001
>> From: Evan Straw <evan.straw99@gmail.com>
>> Date: Tue, 31 Dec 2019 15:31:58 -0800
>> Subject: [PATCH 2/3] gnu: Add liquid-dsp.
>>
>> * gnu/packages/ham-radio.scm (liquid-dsp): New variable.
>
>> +(define-public liquid-dsp
>> +  (let ((commit "f11733208e3d0da928a0dc2111cdb2b0c4817cef")
>> +        (revision "2")
>> +        (version "1.3.2"))
>
> Why this commit and not just the latest release 1.3.2?

It has been a while since liquid-dsp has had a release, so I was
concerned that the software would be out of date and just chose the
latest commit from their git repository. In hindsight there probably
isn't much cause for concern though so I will change it to just the
latest release.

>
>> +      (description "liquid-dsp is a free and open-source digital signal
>> +processing (DSP) library designed specifically for software-defined radios on
>> +embedded platforms. The aim is to provide a lightweight DSP library that does
>> +not rely on a myriad of external dependencies or proprietary and otherwise
>> +cumbersome frameworks. All signal processing elements are designed to be
>> +flexible, scalable, and dynamic, including filters, filter design,
>> +oscillators, modems, synchronizers, complex mathematical operations, and much
>> +more.")
>
> Please remove “free and open-source” — all software in Guix is free
> software, so we don’t need to state it.  Please also use double spacing
> after each sentence.
>

This description was basically just taken from the project's GitHub
page. My apologies, should have checked over it more. I'll change that
too.

Thanks for pointing these things out. I'll send a revision through shortly.

-- Evan Straw
diff mbox series

Patch

From 71f377a45bfc830ff207cd56fa2d8fe0225a6874 Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Tue, 31 Dec 2019 15:31:58 -0800
Subject: [PATCH 2/3] gnu: Add liquid-dsp.

* gnu/packages/ham-radio.scm (liquid-dsp): New variable.
---
 gnu/packages/ham-radio.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index e82865f2f5..f327ea22da 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -22,6 +22,8 @@ 
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libusb)
@@ -127,3 +129,34 @@  satellites, the POES NOAA weather satellite series.  These transmissions are
 on a frequency of 137 MHz.  They can be received using an inexpensive antenna
 and a dedicated receiver.")
     (license license:gpl2+)))
+
+(define-public liquid-dsp
+  (let ((commit "f11733208e3d0da928a0dc2111cdb2b0c4817cef")
+        (revision "2")
+        (version "1.3.2"))
+    (package
+      (name "liquid-dsp")
+      (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jgaeddert/liquid-dsp")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "06f8akc88xi6kaa6fx73pfb9fs7x6y7jjwb4vwkzsvsxj20jshki"))))
+      (build-system gnu-build-system)
+      (native-inputs `(("autoconf" ,autoconf)))
+      (home-page "https://liquidsdr.org")
+      (synopsis "Digital signal processing library for software-defined radios")
+      (description "liquid-dsp is a free and open-source digital signal
+processing (DSP) library designed specifically for software-defined radios on
+embedded platforms. The aim is to provide a lightweight DSP library that does
+not rely on a myriad of external dependencies or proprietary and otherwise
+cumbersome frameworks. All signal processing elements are designed to be
+flexible, scalable, and dynamic, including filters, filter design,
+oscillators, modems, synchronizers, complex mathematical operations, and much
+more.")
+      (license license:expat))))
+
-- 
2.20.1