diff mbox series

[bug#39697] Update PHP to 7.4.3.

Message ID 874kvlmbyg.fsf@gmail.com
State Accepted
Headers show
Series [bug#39697] Update PHP to 7.4.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alex Sassmannshausen Feb. 20, 2020, 4:59 p.m. UTC
Hello,

Please find attached a patch to update PHP to 7.4.3.  This skips 7.4.2.
I had to disable 2 more GD patches to get it to build.

Best wishes,

Alex

Comments

Julien Lepiller Feb. 20, 2020, 5:08 p.m. UTC | #1
Le 20 février 2020 11:59:35 GMT-05:00, Alex Sassmannshausen <alex.sassmannshausen@gmail.com> a écrit :
>Hello,
>
>Please find attached a patch to update PHP to 7.4.3.  This skips 7.4.2.
>I had to disable 2 more GD patches to get it to build.
>
>Best wishes,
>
>Alex

A description of the failures would hade been great, but sure. I'll try to build it anl if it works, will push tonight, thank you!
Alex Sassmannshausen Feb. 20, 2020, 5:11 p.m. UTC | #2
Julien Lepiller <julien@lepiller.eu> writes:

> Le 20 février 2020 11:59:35 GMT-05:00, Alex Sassmannshausen <alex.sassmannshausen@gmail.com> a écrit :
>>Hello,
>>
>>Please find attached a patch to update PHP to 7.4.3.  This skips 7.4.2.
>>I had to disable 2 more GD patches to get it to build.
>>
>>Best wishes,
>>
>>Alex
>
> A description of the failures would hade been great, but sure. I'll
> try to build it anl if it works, will push tonight, thank you!

OK, I'll bear this in mind for next time.  Thanks!

Alex
Julien Lepiller Feb. 21, 2020, 1:54 a.m. UTC | #3
Le Thu, 20 Feb 2020 18:11:21 +0100,
Alex Sassmannshausen <alex.sassmannshausen@gmail.com> a écrit :

> Julien Lepiller <julien@lepiller.eu> writes:
> 
> > Le 20 février 2020 11:59:35 GMT-05:00, Alex Sassmannshausen
> > <alex.sassmannshausen@gmail.com> a écrit :  
> >>Hello,
> >>
> >>Please find attached a patch to update PHP to 7.4.3.  This skips
> >>7.4.2. I had to disable 2 more GD patches to get it to build.
> >>
> >>Best wishes,
> >>
> >>Alex  
> >
> > A description of the failures would hade been great, but sure. I'll
> > try to build it anl if it works, will push tonight, thank you!  
> 
> OK, I'll bear this in mind for next time.  Thanks!
> 
> Alex

Pushed as 2940b3e16ca3ad61b8d9159448a2e42d1fba2c2a, thank you!
diff mbox series

Patch

From 0c12f3923fa0c5b0cada69fceba89ceb6738beee Mon Sep 17 00:00:00 2001
From: Alex Sassmannshausen <alex@komputilo.eu>
Date: Thu, 20 Feb 2020 17:55:38 +0100
Subject: [PATCH] gnu: php: Update to 7.4.3.

* gnu/packages/php.scm (php): Update to 7.4.3.
---
 gnu/packages/php.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index a82257c582..7bb88a7270 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -59,7 +59,7 @@ 
 (define-public php
   (package
     (name "php")
-    (version "7.4.1")
+    (version "7.4.3")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -67,7 +67,7 @@ 
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "0qn7zwf2jzj3h7p4b1l79lf9gv236mycwkhgw15hj2fmpmkbh6sn"))
+                "0alqqs5hn4jmz1adrbysbw92n55nkw6f9vfivqj829kwhxnqa7yg"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -237,6 +237,9 @@ 
                          ;; complete.  It's a warning in both cases and test
                          ;; result is the same.
                          "ext/gd/tests/bug77973.phpt"
+                         ;; New test failures added with 7.4.3
+                         "ext/gd/tests/bug79067.phpt"
+                         "ext/gd/tests/bug79068.phpt"
 
                          ;; XXX: These iconv tests have the expected outcome,
                          ;; but with different error messages.
-- 
2.23.0