diff mbox series

[bug#40696] Status: New package 'r-bridgesampling"

Message ID 874ktfcmdv.fsf@ericcbrown.com
State Accepted
Headers show
Series [bug#40696] Status: New package 'r-bridgesampling" | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Eric Brown April 19, 2020, 7:21 p.m. UTC
bug#40696 <40696@debbugs.gnu.org> writes:

> retitle 40696 New package 'r-bridgesampling"
> reassign 40696 guix-patches
> submitter 40696 Eric Brown <ecbrown@ericcbrown.com>
> severity 40696 normal
>
> thanks

In response to rekado's observation that the first patch will not apply
to master, I have created a second patch to try.

From the feature branch I was developing on:
  git format-patch master




From 152d58d7c813e6b16838ebccc450e6c53594e58a Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Sun, 19 Apr 2020 14:07:27 -0500
Subject: [PATCH] gnu: Add r-bridgesampling.

* gnu/packages/cran.scm (r-bridgesampling): New variable.
---
 gnu/packages/cran.scm | 34 +++++++++++++++++++++++++++++++++-
 1 file changed, 33 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus April 22, 2020, 11:59 a.m. UTC | #1
Eric Brown <ecbrown@ericcbrown.com> writes:

> In response to rekado's observation that the first patch will not apply
> to master, I have created a second patch to try.

Thank you!

I pushed this (with minor changes) to the master branch with commit
e68c8d3ef8d59b8c81fedd8fe9ea38f51cb9437a.

--
Ricardo
diff mbox series

Patch

From 152d58d7c813e6b16838ebccc450e6c53594e58a Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Sun, 19 Apr 2020 14:07:27 -0500
Subject: [PATCH] gnu: Add r-bridgesampling.

* gnu/packages/cran.scm (r-bridgesampling): New variable.
---
 gnu/packages/cran.scm | 34 +++++++++++++++++++++++++++++++++-
 1 file changed, 33 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 757f809941..f9e0686ccf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14,13 +14,13 @@ 
 ;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
 ;;; Copyright © 2020 Danjela Lura <danielaluraa@gmail.com>
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
+;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21131,3 +21131,35 @@  vignettes from notebooks.  Those notebooks (@code{.ipynb} files) are files
 containing rich text, code, and its output.  Code cells can be edited and
 evaluated interactively.")
     (license license:gpl3)))
+
+(define-public r-bridgesampling
+  (package
+    (name "r-bridgesampling")
+    (version "1.0-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "bridgesampling" version))
+       (sha256
+        (base32
+         "1awhvv0v42w2q6llqi1wqpaiv5zx74cqzigdsvphy2jfp8ajw64y"))))
+    (properties
+     `((upstream-name . "bridgesampling")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-brobdingnag" ,r-brobdingnag)
+       ("r-coda" ,r-coda)
+       ("r-matrix" ,r-matrix)
+       ("r-mvtnorm" ,r-mvtnorm)
+       ("r-scales" ,r-scales)
+       ("r-stringr" ,r-stringr)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+     "https://github.com/quentingronau/bridgesampling")
+    (synopsis
+     "Bridge Sampling for Marginal Likelihoods and Bayes Factors")
+    (description
+     "This package provides functions for estimating marginal likelihoods,
+Bayes factors, posterior model probabilities, and normalizing constants in
+general, via different versions of bridge sampling.")
+  (license license:gpl2+)))
-- 
2.26.1