diff mbox series

[bug#53148] gnu: java-snakeyaml: Fix the source URI

Message ID 874k6clhek.fsf@gmail.com
State New
Headers show
Series [bug#53148] gnu: java-snakeyaml: Fix the source URI | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov Jan. 9, 2022, 9:37 p.m. UTC
As lilyp pointed out in IRC the project is just moved to the new
location; the official repo is still on BitBucket:
  https://bitbucket.org/snakeyaml/snakeyaml

I've updated the patch accordingly.

- Artyom

Comments

M Jan. 9, 2022, 10:06 p.m. UTC | #1
Artyom V. Poptsov schreef op ma 10-01-2022 om 00:37 [+0300]:
>                (method url-fetch)
> -              (uri (string-append
> "https://bitbucket.org/asomov/snakeyaml/get/v"
> +              (uri (string-append
> "https://bitbucket.org/snakeyaml/snakeyaml/get/v"
>                                    version ".tar.gz"))
>                (file-name (string-append name "-" version ".tar.gz"))

I compared the result of "guix build --source java-snakeyaml"
before this change with
"guix download https://bitbucket.org/snakeyaml/snakeyaml/get/v1.18.tar.gz".

There are some small differences in the tarball:

│ │┄ Files identical despite different names
│ │   --- asomov-snakeyaml-
97aa6dd6be26/src/test/resources/recursive/with-children-as-set.yaml
│ ├── +++ snakeyaml-snakeyaml-
97aa6dd6be26/src/test/resources/recursive/with-children-as-set.yaml

So it seems like these tarballs are autogenerated.
Seems like we need to switch to git-fetch, and investigate
other tarballs from bitbucket.org as well?
diff mbox series

Patch

From fc99292c63df22b01f6c65a6098e0bbdc1d7e3e0 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 9 Jan 2022 23:20:35 +0300
Subject: [PATCH] gnu: java-snakeyaml: Fix the source URI

* gnu/packages/java.scm (java-snakeyaml): The project seems to be moved from
  <https://bitbucket.org/asomov/snakeyaml> to
  <https://bitbucket.org/snakeyaml/snakeyaml>; update the URI to match the
  actual one.
---
 gnu/packages/java.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e54d2ed0cb..278fdc9f18 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9917,7 +9918,7 @@  of deserialization.")
     (version "1.18")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://bitbucket.org/asomov/snakeyaml/get/v"
+              (uri (string-append "https://bitbucket.org/snakeyaml/snakeyaml/get/v"
                                   version ".tar.gz"))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
@@ -9930,7 +9931,7 @@  of deserialization.")
        ;; Tests require velocity, a cyclic dependency, and
        ;; java-spring-framework-context which is not packaged.
        #:tests? #f))
-    (home-page "https://bitbucket.org/asomov/snakeyaml")
+    (home-page "https://bitbucket.org/snakeyaml/snakeyaml/")
     (synopsis "YAML processor")
     (description "SnakeYAML is a YAML processor for the Java Virtual Machine.")
     (license license:asl2.0))); found on wiki.fasterxml.com/JacksonLicensing
-- 
2.25.1