From 04f1320d53b23f972a1be82e8d8b47128ea27d22 Mon Sep 17 00:00:00 2001
From: Haider Mirza <x7and7@gmail.com>
Date: Fri, 10 Jun 2022 20:08:19 +0100
Subject: [PATCH] gnu: Add emacs-org-auto-tangle.
* gnu/packages/emacs-xyz.scm (emacs-org-auto-tangle): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -113,6 +113,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18639,6 +18640,26 @@ (define-public emacs-bing-dict
Chinese to English.")
(license license:gpl3+)))
+(define-public emacs-org-auto-tangle
+ (package
+ (name "emacs-org-auto-tangle")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yilkalargaw/org-auto-tangle.git")
+ (commit version)))
+ (sha256
+ (base32
+ "1zb7vcmhmjiqpbbhqrqci689rnpn10p985cs5jk9sgg66xsbrgs3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-async))
+ (home-page "https://github.com/yilkalargaw/org-auto-tangle")
+ (synopsis "Automatically tangle code blocks on save")
+ (description
+ "org-auto-tangle is a Emacs Orgmode package that allows you to automatically run org-babel-tangle when saving an orgmode document.")
+ (license license:bsd-2)))
+
(define-public emacs-org-auto-expand
(let ((commit "4938d5f6460e2f8f051ba9ac000b291bfa43ef62")
(revision "1"))
--
2.36.1