diff mbox series

[bug#61397] gnu: hyfetch: Update to 1.4.6.

Message ID 874jru11lv.wl-hako@ultrarare.space
State New
Headers show
Series [bug#61397] gnu: hyfetch: Update to 1.4.6. | expand

Commit Message

Hilton Chain Feb. 10, 2023, 6:22 a.m. UTC
* gnu/packages/admin.scm (hyfetch): Update to 1.4.6.
[inputs]: Remove python-hypy-utils.
[arguments]<#:tests?>: Disable tests.
<#:phases>: Remove set-HOME phase.
Replace install phase to one w/o byte-compilation.
---
 gnu/packages/admin.scm | 24 +++++++++++++++++-------
 1 file changed, 17 insertions(+), 7 deletions(-)


base-commit: b8f6ead5faac3c1b9a8fa6e060c00cf0917e884e

Comments

Liliana Marie Prikler Feb. 10, 2023, 6:04 p.m. UTC | #1
Am Freitag, dem 10.02.2023 um 14:22 +0800 schrieb Hilton Chain:
> 
> * gnu/packages/admin.scm (hyfetch): Update to 1.4.6.
> [inputs]: Remove python-hypy-utils.
> [arguments]<#:tests?>: Disable tests.
> <#:phases>: Remove set-HOME phase.
> Replace install phase to one w/o byte-compilation.
> ---
>  gnu/packages/admin.scm | 24 +++++++++++++++++-------
>  1 file changed, 17 insertions(+), 7 deletions(-)
> 
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 9a82740eb6..8d06b5379e 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -3922,19 +3922,29 @@ (define-public neofetch
>  (define-public hyfetch
>    (package
>      (name "hyfetch")
> -    (version "1.4.4")
> +    (version "1.4.6")
>      (source
>        (origin
>          (method url-fetch)
>          (uri (pypi-uri "HyFetch" version))
>          (sha256
> -          (base32
> "1k3pcl16y2czkk7wd79yk0w1kqpi4fp8h8szhjs5ywwy20nqmms8"))))
> +          (base32
> "1vpknh08vhwyvjg7p8id3hvlq1yv7yjw8xxgjf0rmx3b1k2mpww1"))))
>      (build-system python-build-system)
> -    (inputs (list python-hypy-utils python-typing-extensions))
> -    (arguments `(#:phases (modify-phases %standard-phases
> -                            (add-before 'build 'set-HOME
> -                              (lambda _  ;; Tries to set files in
> .config
> -                                (setenv "HOME" "/tmp"))))))
> +    (inputs (list python-typing-extensions))
> +    (arguments
> +     (list #:tests? #f    ;FIXME: `SyntaxError: invalid syntax` in
> some logos.
Don't blindly disable tests.  Fix the syntax error instead.


Cheers
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9a82740eb6..8d06b5379e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3922,19 +3922,29 @@  (define-public neofetch
 (define-public hyfetch
   (package
     (name "hyfetch")
-    (version "1.4.4")
+    (version "1.4.6")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "HyFetch" version))
         (sha256
-          (base32 "1k3pcl16y2czkk7wd79yk0w1kqpi4fp8h8szhjs5ywwy20nqmms8"))))
+          (base32 "1vpknh08vhwyvjg7p8id3hvlq1yv7yjw8xxgjf0rmx3b1k2mpww1"))))
     (build-system python-build-system)
-    (inputs (list python-hypy-utils python-typing-extensions))
-    (arguments `(#:phases (modify-phases %standard-phases
-                            (add-before 'build 'set-HOME
-                              (lambda _  ;; Tries to set files in .config
-                                (setenv "HOME" "/tmp"))))))
+    (inputs (list python-typing-extensions))
+    (arguments
+     (list #:tests? #f    ;FIXME: `SyntaxError: invalid syntax` in some logos.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Copied from the original install phase, w/o byte-compiling.
+               ;; Since the same error in test occurs with that.
+               (replace 'install
+                 (lambda _
+                   (let ((params (list (string-append "--prefix=" #$output)
+                                       "--no-compile"
+                                       "--single-version-externally-managed"
+                                       "--root=/")))
+                     ((@@ (guix build python-build-system)
+                          call-setuppy) "install" params #t)))))))
     (home-page "https://github.com/hykilpikonna/HyFetch")
     (synopsis "@code{neofetch} with pride flags <3")
     (description "HyFetch is a command-line system information tool fork of