diff mbox series

[bug#69020] gnu: go-github-com-prometheus-procfs: Add missing input.

Message ID 874jegb2e5.fsf@troyfigiel.com
State New
Headers show
Series [bug#69020] gnu: go-github-com-prometheus-procfs: Add missing input. | expand

Commit Message

Troy Figiel Feb. 10, 2024, 6:19 p.m. UTC
* gnu/packages/golang.scm (go-github-com-prometheus-procfs): Add missing
input.
[propagated-inputs]: Add go-golang.org-x-sync-errgroup.
---
 gnu/packages/golang.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: e257de4365b24a84f39813aea2e8b4ab6259f283

Comments

Sharlatan Hellseher Feb. 13, 2024, 9:44 p.m. UTC | #1
Hi,

Pushed as 9b095daa2986cdb48500f6eb24dc79bf4178705f to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 163691a1e6..255e7e9861 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9231,6 +9231,7 @@  (define-public go-github-com-prometheus-procfs
        ;; The tests require Go modules, which are not yet supported in Guix's
        ;; Go build system.
        #:tests? #f))
+    (propagated-inputs (list go-golang.org-x-sync-errgroup))
     (synopsis "Go library for reading @file{/proc}")
     (description "The @code{procfs} Go package provides functions to retrieve
 system, kernel, and process metrics from the @file{/proc} pseudo file system.")