diff mbox series

bug#68829: [PATCH 3/3] gnu: Add git-sizer.

Message ID 874je5n713.fsf@gnu.org
State New
Headers show
Series bug#68829: [PATCH 3/3] gnu: Add git-sizer. | expand

Commit Message

Ludovic Courtès Feb. 18, 2024, 3:09 p.m. UTC
Hi,

Greg Hogan <code@greghogan.com> skribis:

> * gnu/packages/version-control.scm (git-sizer): New variable.
>
> Change-Id: I82a61e364782dabfd59d0e81ff310fa916b5ff23

Applied with the change below (suggested by ‘guix lint’).

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ee6cd78107..afef900bbb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4028,12 +4028,14 @@  (define-public git-sizer
                 (string-append (assoc-ref outputs "out")
                                "/bin/git-sizer")))))
          (replace 'check
-           (lambda* (#:key import-path #:allow-other-keys)
-             (for-each (lambda (test)
-                         (invoke "go" "test" "-v" "-run" test import-path))
-                       ;; TestExec and TestSubmodule require a copy of the Git repository.
-                       '("TestBomb" "TestFromSubdir" "TestRefgroups"
-                         "TestRefSelections" "TestTaggedTags")))))))
+           (lambda* (#:key tests? import-path #:allow-other-keys)
+             (when tests?
+               (for-each (lambda (test)
+                           (invoke "go" "test" "-v" "-run" test import-path))
+                         ;; TestExec and TestSubmodule require a copy of the
+                         ;; Git repository.
+                         '("TestBomb" "TestFromSubdir" "TestRefgroups"
+                           "TestRefSelections" "TestTaggedTags"))))))))
     (native-inputs (list git))
     (propagated-inputs
      (list go-github-com-cli-safeexec