[bug#72541] gnu: gerbv: Fix missing version.
Commit Message
I tried to contact upstream, but they don't accept pull requests:
- https://github.com/gerbv/gerbv/issues/244
- https://github.com/gerbv/gerbv/pull/226#issuecomment-2566103734
So it can only be done here. I updated initial patch with suggested
configure flags and commented why git is added to native inputs.
From f85ab2e24f0da292f639c07f4d66430896b18d13 Mon Sep 17 00:00:00 2001
Message-ID: <f85ab2e24f0da292f639c07f4d66430896b18d13.1735929709.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Fri, 3 Jan 2025 21:40:01 +0300
Subject: [PATCH] gnu: gerbv: Fix missing version.
* gnu/packages/engineering.scm (gerbv): Fix missing version.
[source]: Change indentation.
[arguments]: Set correct configure flags, patch version generator shebang.
Change-Id: I29a38fff03127d9ce2b5e04ca638dacfc3720125
---
gnu/packages/engineering.scm | 32 +++++++++++++++++++++-----------
1 file changed, 21 insertions(+), 11 deletions(-)
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
-;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
+;;; Copyright © 2022, 2025 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 Olivier Dion <olivier.dion@polymtl.ca>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -837,22 +837,32 @@ (define-public gerbv
(package
(name "gerbv")
(version "2.10.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gerbv/gerbv")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gerbv/gerbv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("CFLAGS=-fcommon")))
+ (list
+ #:configure-flags #~(list "CFLAGS=-O2 -g -fcommon")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-version-generator
+ (lambda _
+ (substitute* "utils/git-version-gen.sh"
+ (("/bin/bash")
+ (which "bash"))))))))
(native-inputs (list autoconf
automake
desktop-file-utils
gettext-minimal
+ ;; Version generator needs git to work properly:
+ ;; https://github.com/gerbv/gerbv/issues/244
+ git
`(,glib "bin")
libtool
pkg-config))
base-commit: ce3ffac5d366ebf20e0d95779f2fe1ea6dde0202
--
2.47.1