[bug#78135,tex-team] gnu: texstudio: Update to 4.8.7.

Message ID 8745846044bc4d8dd4d8f87f330f6da2bade4d7e.1745936109.git.code@greghogan.com
State New
Headers
Series [bug#78135,tex-team] gnu: texstudio: Update to 4.8.7. |

Commit Message

Greg Hogan April 29, 2025, 2:16 p.m. UTC
  * gnu/packages/tex.scm (texstudio): Update to 4.8.7.

Change-Id: Ia8ebfca22da6a05225601560d7295f30d9dff18a
---
 gnu/packages/tex.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 32bc7695b50a2018f15618a86d7200fc8c3e2f58
  

Comments

Nicolas Goaziou April 29, 2025, 3:24 p.m. UTC | #1
Hello,

Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/tex.scm (texstudio): Update to 4.8.7.

Thank you.

Note that you already updated it to 4.8.6 on "tex-team" branch, which is
hopefully soon to be merged.

I suggest to wait for that to happen and then do the bump to 4.8.7
directly from master. WDYT?

Regards,
  
Greg Hogan April 29, 2025, 3:36 p.m. UTC | #2
On Tue, Apr 29, 2025 at 11:24 AM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> Greg Hogan <code@greghogan.com> writes:
>
> > * gnu/packages/tex.scm (texstudio): Update to 4.8.7.
>
> Thank you.
>
> Note that you already updated it to 4.8.6 on "tex-team" branch, which is
> hopefully soon to be merged.
>
> I suggest to wait for that to happen and then do the bump to 4.8.7
> directly from master. WDYT?
>
> Regards,
> --
> Nicolas Goaziou

Yes, I think there is some confusion over team branches and master.
From the documentation [0]: "Any changes that can be made on the
master branch, should be made on the master branch. If a commit can be
split to apply part of the changes on master, this is good to do."

texstudio has no dependent packages, so should be pushed directly to
master. My understanding is that it still needs to be either approved
or pushed by the owning team.

Or maybe it's not confusion, just that QA is generally unhelpful and
teams are using their branches as a replacement. And with no automated
or accurate method to compute the build cost simple patches get lumped
in with complex updates.
  
Andreas Enge April 29, 2025, 4:54 p.m. UTC | #3
Hello Greg,

Am Tue, Apr 29, 2025 at 11:36:13AM -0400 schrieb Greg Hogan:
> texstudio has no dependent packages, so should be pushed directly to
> master. My understanding is that it still needs to be either approved
> or pushed by the owning team.

I do not think this is necessary for non-disruptive changes after
verifying, for instance, that they pass QA.

Andreas
  
Nicolas Goaziou April 29, 2025, 5:12 p.m. UTC | #4
Hello,

Greg Hogan <code@greghogan.com> writes:

> Yes, I think there is some confusion over team branches and master.
> From the documentation [0]: "Any changes that can be made on the
> master branch, should be made on the master branch. If a commit can be
> split to apply part of the changes on master, this is good to do."
>
> texstudio has no dependent packages, so should be pushed directly to
> master. My understanding is that it still needs to be either approved
> or pushed by the owning team.

You are right, it should have been pushed directly to master, not to
tex-team branch. But what is done is done!

> Or maybe it's not confusion, just that QA is generally unhelpful and
> teams are using their branches as a replacement. And with no automated
> or accurate method to compute the build cost simple patches get lumped
> in with complex updates.

It probably depends on the team. For example, there is no accurate
method to compute the build cost of a Rust package update, so the branch
indeed collects all the updates from all Rust packages, although it is
evolving. For other packages, guix refresh gives you a good idea of the
cost of an update.

Also some teams have a clear focus, e.g. updating Gnome. As for the tex
team, it exists because of the large numbers of builds implied by
changes to texlive packages. So it should mainly include
world-rebuilding changes.

Regards,
  

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 04632e8408..e4b8943e57 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -71822,7 +71822,7 @@  (define-public texmaker
 (define-public texstudio
   (package
     (name "texstudio")
-    (version "4.8.2")
+    (version "4.8.7")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -71831,7 +71831,7 @@  (define-public texstudio
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1grkvwh174a2dx19w6wlkhq2adj6g2myy31f5hji7kxw4ks759xb"))))
+                "1z17j1wggs8fgjqk0mrqqwh7xcsmzckfhlpwc7aykr65ii4gqizz"))))
     (build-system qt-build-system)
     (arguments
      `(#:tests? #f))                    ;tests work only with debug build