[bug#33986,8/9] gnu: Add ocaml-ppx-derivers.

Message ID 8736q78369.fsf@gmail.com
State Accepted
Headers show
Series [bug#33986,1/9] gnu: Add ocaml-sexplib0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 5, 2019, 4:44 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-derivers): New variable.
---
 gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dddad4f33..04b6dea8f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5328,3 +5328,29 @@  and/or previous version.")
 It re-exports the input/output functions of the OCaml standard
 libraries using a more consistent API.")
     (license license:expat)))
+
+(define-public ocaml-ppx-derivers
+  (package
+    (name "ocaml-ppx-derivers")
+    (version "1.2")
+    (home-page
+     "https://github.com/ocaml-ppx/ppx_derivers")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0bnhihl1w31as5w2czly1v3d6pbir9inmgsjg2cj6aaj9v1dzd85"))))
+    (build-system dune-build-system)
+    (arguments
+     '(#:tests? #f)) ;no tests
+    (synopsis "Shared [@@deriving] plugin registry")
+    (description
+     "Ppx_derivers is a tiny package whose sole purpose is to allow
+ppx_deriving and ppx_type_conv to inter-operate gracefully when linked
+as part of the same ocaml-migrate-parsetree driver.")
+    (license license:bsd-3)))