bug#34953: Add xfce4-whiskermenu-plugin

Message ID 8736ncszcp.fsf@gnu.org
State Accepted
Headers show
Series bug#34953: Add xfce4-whiskermenu-plugin | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès March 24, 2019, 10:04 p.m. UTC
Hello,

<pkill9@runbox.com> skribis:

> Attached is a patch that adds the Whiskermenu panel plugin for Xfce: https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin
>
> I originally had GTK+ added as an input, and the configure phase searches for it, but since it builds fine without GTK+ I've removed it. If Garcon is removed then it errors on not finding GTK+, but I don't know, if it works then *shrug*.

What happens is that GTK+ gets propagated via Garcon, which is why it
works even if you don’t add it as an input.  However, since this package
clearly has a direct dependency on GTK+, we should add it to ‘inputs’.

> From e7a99c0c1fea1549b08cd2e4a1c540a3a0091675 Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Sat, 23 Mar 2019 11:49:52 +0000
> Subject: [PATCH] gnu: Add xfce4-whiskermenu-plugin.
>
> * gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): New variable.

Applied with the changes below.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index f716bd01eb..8543dcffed 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -427,17 +427,18 @@  keys for controlling the audio volume.")
     (inputs
      `(("xfce4-panel" ,xfce4-panel)
        ("garcon" ,garcon)
-       ("exo" ,exo)))
+       ("exo" ,exo)
+       ("gtk+" ,gtk+-2)))
     (arguments
       `(#:tests? #f)) ; no tests
     (home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin")
     (synopsis "Application menu panel plugin for Xfce")
     (description
-     "An alternative to the default application menu panel plugin for Xfce4.
-It uses separate sections to display categories and applications, and
-includes a search bar to search for applications.")
-    ;;The main plugin code is covered by gpl2, but files in panel-plugin directory
-    ;;are covered by gpl2+. The SVG icon is covered by gpl2.
+     "This package provides an alternative to the default application menu
+panel plugin for Xfce4.  It uses separate sections to display categories and
+applications, and includes a search bar to search for applications.")
+    ;; The main plugin code is covered by gpl2, but files in panel-plugin directory
+    ;; are covered by gpl2+.  The SVG icon is covered by gpl2.
     (license (list gpl2 gpl2+))))
 
 (define-public xfce4-xkb-plugin