diff mbox series

[bug#38552,1/1] gnu: ruby: Configure for dynamic linking.

Message ID 8736dtusml.fsf@posteo.net
State Accepted
Headers show
Series [bug#38552,1/1] gnu: ruby: Configure for dynamic linking. | expand

Commit Message

Brett Gilio Dec. 9, 2019, 8:54 p.m. UTC

Comments

Jonathan Brielmaier Dec. 9, 2019, 9:12 p.m. UTC | #1
On 09.12.19 21:54, Brett Gilio wrote:
> Subject: [PATCH 1/1] gnu: ruby: Configure for dynamic linking.
> To: guix-patches@gnu.org
>
> * gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to properly
>   enable dynamic linking instead of using libruby-static.a. Solves #38500.
>
> Reported-by: Vicente Eduardo <vic798@gmail.com>

Maybe change the commit format a little:

Fixes <https://bugs.gnu.org/38500>.
Reported-by: Vicente Eduardo <vic798@gmail.com>

* gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to
properly enable dynamic linking instead of using libruby-static.a.
Brett Gilio Dec. 9, 2019, 10:13 p.m. UTC | #2
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
>
> Maybe change the commit format a little:
>
> Fixes <https://bugs.gnu.org/38500>.
> Reported-by: Vicente Eduardo <vic798@gmail.com>
>
> * gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to
> properly enable dynamic linking instead of using libruby-static.a.


Sounds like a good idea. Consider it done.

I will wait for more eyes before pushing to core-updates. Thank you Jonathan.
Brett Gilio Dec. 13, 2019, 3:49 a.m. UTC | #3
Pushed to core-updates with fd248cb815d571043c3a0c52a01c9b3e368a069e.

Closing.
diff mbox series

Patch

From 36e56ea5d882d112f24d49050813066eece98af2 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 9 Dec 2019 14:46:47 -0600
Subject: [PATCH 1/1] gnu: ruby: Configure for dynamic linking.
To: guix-patches@gnu.org

* gnu/packages/ruby.scm (ruby)[arguments]: Use #:configure-flags to properly
  enable dynamic linking instead of using libruby-static.a. Solves #38500.

Reported-by: Vicente Eduardo <vic798@gmail.com>
---
 gnu/packages/ruby.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 70b59e9156..a4b9bc6968 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
 ;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -95,6 +96,7 @@ 
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
+       #:configure-flags '("--enable-shared") ; dynamic linking
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'replace-bin-sh-and-remove-libffi
-- 
2.24.0