From ada62b2a6497b557bb5ca3e27c72f1a16d8b401a Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Tue, 31 Dec 2019 19:04:37 -0800
Subject: [PATCH 3/3] gnu: Add redsea.
* gnu/packages/ham-radio.scm (redsea): New variable.
---
gnu/packages/ham-radio.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
@@ -156,3 +156,48 @@ including filters, filter design, oscillators, modems, synchronizers, complex
mathematical operations, and much more.")
(license license:expat)))
+(define-public redsea
+ (package
+ (name "redsea")
+ (version "0.18")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/windytan/redsea")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y96g0ra2krjb2kypm8s5gdfia45yci4f36klsvyzg8d53v5cwhn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The configure.ac file does not explicitly link against libiconv
+ ;; except on Mac OS, causing the build to fail. This phase comments
+ ;; out the original AC_SUBST macro (located inside a conditional) and
+ ;; adds an explicit use of it underneath, so that libiconv is always
+ ;; linked against.
+ (add-after 'unpack 'patch-libiconv
+ (lambda _
+ (substitute* "configure.ac"
+ (("^ +AC_SUBST")
+ "# AC_SUBST")
+ (("esac")
+ "esac\nAC_SUBST([ICONV], [\"-liconv\"])"))
+ #t)))))
+ (inputs
+ `(("libiconv" ,libiconv)
+ ("libsndfile" ,libsndfile)
+ ("liquid-dsp" ,liquid-dsp)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (home-page "https://github.com/windytan/redsea")
+ (synopsis "Lightweight RDS to JSON decoder")
+ (description "redsea is a lightweight command-line @dfn{FM Radio Data
+System} (FM-RDS) decoder. Redsea can be used with any RTL-SDR USB radio stick
+with the rtl_fm tool, or any other @dfn{software-defined radio} (SDR) via
+csdr, for example. It can also decode raw ASCII bitstream, the hex format
+used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
+ (license license:expat)))
--
2.20.1