diff mbox series

bug#40438: [PATCH] gnu: Add jsonrpc-glib.

Message ID 87369itib7.fsf@gmail.com
State Accepted
Headers show
Series bug#40438: [PATCH] gnu: Add jsonrpc-glib. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Mathieu Othacehe April 5, 2020, 9:04 a.m. UTC
Hello Alexandros,

I pushed this one with the following modifications:


Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 30a897971e..5954b8cf7c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9962,29 +9962,29 @@  audio files.")
 (define-public jsonrpc-glib
   (package
     (name "jsonrpc-glib")
-    (version "3.32.0")
+    (version "3.34.0")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://gitlab.gnome.org/GNOME/jsonrpc-glib.git")
-                     (commit version)))
-              (file-name (string-append name "-" version "-checkout"))
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                   name "-" version ".tar.xz"))
               (sha256
-                (base32
-                  "0mjr4g6jm3nwsjw0mnwnxr7ndnzaq2b2pr92xk1dmnca5znmal34"))))
+               (base32
+                "0j05x4xv2cp3cbmp30m68z8g4rdw7b030ip4wszyfj9ya15v5kni"))))
     (build-system meson-build-system)
     (inputs
-     `(("glib" ,glib)
+     `(("json-glib" ,json-glib)
+       ("glib" ,glib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
        ("gobject-introspection" ,gobject-introspection)
-       ("json-glib" ,json-glib)
        ("vala" ,vala)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
     (home-page "https://gitlab.gnome.org/GNOME/jsonrpc-glib")
     (synopsis "JSON-RPC library for GLib")
-    (description "Jsonrpc-GLib is a library to communicate with JSON-RPC
-based peers in either a synchronous or asynchronous fashion.  It also
-allows communicating using the GVariant serialization format instead of
-JSON when both peers support it.  You might want that when communicating
-on a single host to avoid parser overhead and memory-allocator fragmentation.")
+    (description "Jsonrpc-GLib is a library to communicate with JSON-RPC based
+peers in either a synchronous or asynchronous fashion.  It also allows
+communicating using the GVariant serialization format instead of JSON when
+both peers support it.  You might want that when communicating on a single
+host to avoid parser overhead and memory-allocator fragmentation.")
     (license license:lgpl2.1+)))