@@ -27,7 +27,6 @@
#:use-module (ice-9 regex)
#:use-module (gnu packages)
#:use-module (gnu packages audio)
- #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
@@ -948,8 +947,8 @@ floating through space.")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://gnu/mdk/v1.2.10/mdk-" version ".tar.gz"))
+ (uri (string-append "mirror://gnu/mdk/v1.2.10/mdk-"
+ version ".tar.gz"))
(sha256
(base32
"1rwcq2b5vvv7318j92nxc5dayj27dpfhzc4rjiv4ccvsc0x35x5h"))))
@@ -960,10 +959,6 @@ floating through space.")
`(("flex" ,flex)
("pkg-config" ,pkg-config)
("intltool" ,intltool)
- ("texinfo" ,texinfo)
- ("gettext" ,gettext-minimal)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
("ncurses" ,ncurses)))
(inputs
`(("readline" ,readline)
@@ -974,7 +969,7 @@ floating through space.")
(home-page "https://www.gnu.org/software/mdk/")
(synopsis "Virtual development environment for Knuth's MIX")
(description
- "GNU MDK is the Mix Development Kit, an emulation of the pedagogical
+ "GNU MDK is the Mix Development Kit, an emulation of the pedagogical
computer MIX and its assembly language MIXAL. MIX has a virtual CPU with
standard features such as registers, memory cells, an overflow toggle,
comparison flags, input-output devices, and a set of binary instructions.
Hi, guy fleury iteriteka <gfleury@disroot.org> skribis: > * gnu/packages/education.scm(mdk): New variable. Applied with the following changes that remove unneeded cruft. Thanks! Ludo’.