diff mbox series

[bug#41395] gnu: Update python-prompt-toolkit to version 3.0.5

Message ID 87367myf82.fsf@alice.lan
State Accepted
Headers show
Series [bug#41395] gnu: Update python-prompt-toolkit to version 3.0.5 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Edouard Klein May 26, 2020, 1:53 p.m. UTC
* gnu/packages/machine-learning.scm (python-iml): Pin implicit
python-prompt-toolkit dependency to version 2.

* gnu/packages/python-xyz.scm (python-widgetsnbextension): Pin implicit
python-prompt-toolkit dependency to version 2.
(python-ipywidgets): Update to version 7.5.1.
(python-ipywidgets): Pin implicit python-prompt-toolkit dependency to version
2.
(python-jupyter-console): Update to version 6.1.0.
(python-jupyter-console): Pin implicit python-prompt-toolkit dependency to
version 2.
(python-jupyter-console): Pin explicit python-prompt-toolkit dependency to
version 2.
(python-prompt-toolkit): Update to version 3.0.5.
(python-prompt-toolkit-2): New variable
(prompt-toolkit-2-instead-of-prompt-toolkit): New variable
(python2-prompt-toolkit): keep at version 2.
(python-prompt-toolkit-1): inherit from version 2.
---
 gnu/packages/machine-learning.scm |  3 +-
 gnu/packages/python-xyz.scm       | 49 +++++++++++++++++++++++--------
 2 files changed, 38 insertions(+), 14 deletions(-)

Comments

Marius Bakke May 30, 2020, 1:48 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/machine-learning.scm (python-iml): Pin implicit
> python-prompt-toolkit dependency to version 2.

I added a [propagated-inputs] here.

> * gnu/packages/python-xyz.scm (python-widgetsnbextension): Pin implicit
> python-prompt-toolkit dependency to version 2.

And here.

> (python-ipywidgets): Update to version 7.5.1.

And removed this.

> (python-ipywidgets): Pin implicit python-prompt-toolkit dependency to version
> 2.

[propagated-inputs]

> (python-jupyter-console): Update to version 6.1.0.

Removed.

> (python-jupyter-console): Pin implicit python-prompt-toolkit dependency to
> version 2.
> (python-jupyter-console): Pin explicit python-prompt-toolkit dependency to
> version 2.

Duplicate.

> (python-prompt-toolkit): Update to version 3.0.5.

I mentioned the changes to [home-page] and [propagated-inputs] here.

> (python-prompt-toolkit-2): New variable
> (prompt-toolkit-2-instead-of-prompt-toolkit): New variable
> (python2-prompt-toolkit): keep at version 2.
> (python-prompt-toolkit-1): inherit from version 2.

And added capitalizations and full stops here.

[...]

> +(define-public python-prompt-toolkit-2
> +  (package (inherit python-prompt-toolkit)
> +    (name "python-prompt-toolkit")
> +    (version "2.0.7")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "0fgacqk73w7s932vy46pan2yp8rvjmlkag20xvaydh9mhf6h85zx"))))
> +    (propagated-inputs
> +     `(("python-wcwidth" ,python-wcwidth)
> +       ("python-six" ,python-six)
> +       ("python-pygments" ,python-pygments)
> +       ("python-wcwidth" ,python-wcwidth)))))

Duplicate wcwidth input (fixed).

> +(define-public prompt-toolkit-2-instead-of-prompt-toolkit
> +  (package-input-rewriting/spec
> +   `(("python-prompt-toolkit" . ,(const python-prompt-toolkit-2)))))

So this procedure is extremely greedy, and creates new derivations of
python-sphinx, python-cython and others for the affected packages.  Not
sure what's going on, but went ahead and applied it anyway.

The patches will be pushed shortly.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 17d01bc656..e26768267b 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1817,7 +1817,8 @@  advanced research.")
          "1k8szlpm19rcwcxdny9qdm3gmaqq8akb4xlvrzyz8c2d679aak6l"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("ipython" ,python-ipython)
+     `(("ipython" ,(prompt-toolkit-2-instead-of-prompt-toolkit
+                    python-ipython))
        ("numpy" ,python-numpy)
        ("pandas" ,python-pandas)
        ("scipy" ,python-scipy)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 76a1635b12..aea4d5aab6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8980,7 +8980,8 @@  interactive computing.")
          "1ismyaxbv9d56yqqqb8xl58hg0iq0bbyy014a53y1g3hfbc8g7q7"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-ipykernel" ,python-ipykernel)
+     `(("python-ipykernel"
+        ,(prompt-toolkit-2-instead-of-prompt-toolkit python-ipykernel))
        ("python-notebook" ,python-notebook)))
     (native-inputs
      `(("python-certifi" ,python-certifi)
@@ -9007,7 +9008,8 @@  notebooks.")
          "15sww2mvnkqlvx55gwa82v05062a8j1xpncnqna4k9sl53hgcig9"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-ipython" ,python-ipython)
+     `(("python-ipython" ,(prompt-toolkit-2-instead-of-prompt-toolkit
+                           python-ipython))
        ("python-traitlets" ,python-traitlets)
        ("python-widgetsnbextension" ,python-widgetsnbextension)))
     (native-inputs
@@ -9037,9 +9039,10 @@  in the data.")
          "06s3kr5vx0l1y1b7fxb04dmrppscl7q69sl9yyfr0d057d1ssvkg"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-ipykernel" ,python-ipykernel)
+     `(("python-ipykernel" ,(prompt-toolkit-2-instead-of-prompt-toolkit
+        python-ipykernel))
        ("python-jupyter-client" ,python-jupyter-client)
-       ("python-prompt-toolkit" ,python-prompt-toolkit)
+       ("python-prompt-toolkit" ,python-prompt-toolkit-2)
        ("python-pygments" ,python-pygments)))
     (native-inputs
      `(("python-nose" ,python-nose)))
@@ -12105,14 +12108,14 @@  collections of data.")
 (define-public python-prompt-toolkit
   (package
     (name "python-prompt-toolkit")
-    (version "2.0.7")
+    (version "3.0.5")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
+       (uri (pypi-uri "prompt_toolkit" version))
        (sha256
         (base32
-         "0fgacqk73w7s932vy46pan2yp8rvjmlkag20xvaydh9mhf6h85zx"))))
+         "1j3x5s4gp4ih73sbcni0a0vffbzvrxbrbnkvb3fzjgxn810ilgan"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -12126,12 +12129,11 @@  collections of data.")
              (add-installed-pythonpath inputs outputs)
              (invoke "py.test"))))))
     (propagated-inputs
-     `(("python-wcwidth" ,python-wcwidth)
-       ("python-six" ,python-six)
-       ("python-pygments" ,python-pygments)))
+     `(("python-wcwidth" ,python-wcwidth)))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
-    (home-page "https://github.com/jonathanslenders/python-prompt-toolkit")
+    (home-page
+     "https://github.com/prompt-toolkit/python-prompt-toolkit")
     (synopsis "Library for building command line interfaces in Python")
     (description
      "Prompt-Toolkit is a library for building interactive command line
@@ -12141,11 +12143,32 @@  code completion, incremental search, support for Chinese double-width
 characters, mouse support, and auto suggestions.")
     (license license:bsd-3)))
 
+(define-public python-prompt-toolkit-2
+  (package (inherit python-prompt-toolkit)
+    (name "python-prompt-toolkit")
+    (version "2.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
+       (sha256
+        (base32
+         "0fgacqk73w7s932vy46pan2yp8rvjmlkag20xvaydh9mhf6h85zx"))))
+    (propagated-inputs
+     `(("python-wcwidth" ,python-wcwidth)
+       ("python-six" ,python-six)
+       ("python-pygments" ,python-pygments)
+       ("python-wcwidth" ,python-wcwidth)))))
+
+(define-public prompt-toolkit-2-instead-of-prompt-toolkit
+  (package-input-rewriting/spec
+   `(("python-prompt-toolkit" . ,(const python-prompt-toolkit-2)))))
+
 (define-public python2-prompt-toolkit
-  (package-with-python2 python-prompt-toolkit))
+  (package-with-python2 python-prompt-toolkit-2))
 
 (define-public python-prompt-toolkit-1
-  (package (inherit python-prompt-toolkit)
+  (package (inherit python-prompt-toolkit-2)
     (version "1.0.15")
     (source
      (origin