diff mbox series

[bug#41566] gnu: Add emacs-erc-status-sidebar.

Message ID 87367le0xu.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41566] gnu: Add emacs-erc-status-sidebar. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 27, 2020, 5:34 p.m. UTC

Comments

Marius Bakke May 30, 2020, 2 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> From 2c47a49177ab0a8ceee52910007a998b73f3bf81 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Wed, 27 May 2020 19:31:46 +0200
> Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.
>
> * gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.

Thanks!
  
> +(define-public emacs-erc-status-sidebar
> +  (package
> +    (name "emacs-erc-status-sidebar")
> +    (version "20171223.2124")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://melpa.org/packages/erc-status-sidebar-"
> +                           version ".el"))
> +       (sha256
> +        (base32 "1jjz4zs4fx45i9nvy2h7nfzkv0qrpp1pfhr8fx3hb6wxvi6zjis0"))))

IIRC melpa.org purges old versions, so we should probably change to
'git-fetch' here.

> +    (build-system emacs-build-system)
> +    (propagated-inputs `(("emacs-seq" ,emacs-seq)))
> +    (home-page "https://github.com/drewbarbs/erc-status-sidebar")
> +    (synopsis "Hexchat-like activity overview for ERC channels")
> +    (description
> +     "This package is provides a hexchat-like status bar for joined
> +channels in ERC.  It relies on the @code{erc-track} module, and displays
> +all the same information erc-track does in the mode line, but in an
> +alternative format.")
> +    (license license:gpl3)))

Well this is awkward, the LICENSE file is GPL3, but the headers in
erc-status-sidebar.el actually uses the Expat license.  So this should
be license:expat.

It would be good to notify upstream about this inconstency, but not a
blocking issue.

Can you send an updated patch?
diff mbox series

Patch

From 2c47a49177ab0a8ceee52910007a998b73f3bf81 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Wed, 27 May 2020 19:31:46 +0200
Subject: [PATCH] gnu: Add emacs-erc-status-sidebar.

* gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 45a10f4689..338bd270e0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3216,6 +3216,28 @@  appropriate console.")
 IRC bouncer with ERC.")
     (license license:expat)))
 
+(define-public emacs-erc-status-sidebar
+  (package
+    (name "emacs-erc-status-sidebar")
+    (version "20171223.2124")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://melpa.org/packages/erc-status-sidebar-"
+                           version ".el"))
+       (sha256
+        (base32 "1jjz4zs4fx45i9nvy2h7nfzkv0qrpp1pfhr8fx3hb6wxvi6zjis0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-seq" ,emacs-seq)))
+    (home-page "https://github.com/drewbarbs/erc-status-sidebar")
+    (synopsis "Hexchat-like activity overview for ERC channels")
+    (description
+     "This package is provides a hexchat-like status bar for joined
+channels in ERC.  It relies on the @code{erc-track} module, and displays
+all the same information erc-track does in the mode line, but in an
+alternative format.")
+    (license license:gpl3)))
+
 (define-public emacs-shut-up
   (package
     (name "emacs-shut-up")
-- 
2.26.2