diff mbox series

[bug#43807] gnu: Add emacs-py-isort.

Message ID 87362t1hf2.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#43807] gnu: Add emacs-py-isort. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 5, 2020, 3:27 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Nicolas Goaziou Oct. 13, 2020, 7:25 a.m. UTC | #1
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> Patch file is attached.

I re-ordered the fields and applied your patch.

Note that I also changed the license to GPL3+, as I couldn't find any
reason to limit it to GPL3. Please let me know if I did a mistake.

Thank you.

Regards,
diff mbox series

Patch

From 37ec91b4161801c6e467b5650445e3d1ba22b128 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 4 Oct 2020 22:26:24 -0500
Subject: [PATCH] gnu: Add emacs-py-isort.

* gnu/packages/emacs-xyz.scm (emacs-py-isort): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4894e20112..8d53cb53f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5646,6 +5646,31 @@  This provides a basic API and common UI widgets such as popup tooltips
 and popup menus.")
     (license license:gpl3+)))
 
+(define-public emacs-py-isort
+  (package
+    (name "emacs-py-isort")
+    (version "2016.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/paetzke/py-isort.el")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08i55gv392wc12x8v3dca0dmz8a8p9ljsqhyajsb6qv1k120wqhx"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/paetzke/py-isort.el")
+    (propagated-inputs
+     `(("python-isort" ,python-isort)))
+    (arguments
+     `(#:tests? #f)) ; tests fail with "emacs: standard input is not a tty"
+    (synopsis "Sort the imports in Python buffers")
+    (description
+     "This package provides commands and a minor mode to sort Python imports
+using @code{python-isort}.")
+    (license license:gpl3)))
+
 (define-public emacs-python-environment
   (package
     (name "emacs-python-environment")
-- 
2.28.0