diff mbox series

[bug#44798] gnu: Add emacs-embark

Message ID 8736118q70.fsf@posteo.net
State Accepted
Headers show
Series [bug#44798] gnu: Add emacs-embark | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Nov. 22, 2020, 1:40 p.m. UTC

Comments

Arun Isaac Nov. 23, 2020, 6:45 p.m. UTC | #1
Thanks for the patch! I pushed to master with the following minor edits.

> +  ;; There are no tagged releases upstream on gitlab, instead we are using
> +  ;; the most recent commit.

I think you meant github, not gitlab.

> +  (let ((commit "dc20b4e53c4ce1ad91100dfeb093115f2cc0b210")
> +        (revision "0"))
> +    (package
> +      (name "emacs-embark")
> +      (version (git-version "0.6" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/oantolin/embark")
> +               (commit commit)))
> +         (sha256
> +          (base32 "1jrvdlwip7zll5ixlnk9l0apr8hj60ysqfc47q3k4hhfyl9rawbq"))
> +         (file-name (git-file-name name version))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs
> +       `(("emacs-avy" ,emacs-avy)))
> +      (home-page "https://github.com/oantolin/embark")
> +      (synopsis "Emacs Mini-Buffer Actions Rooted in Keymaps")

I capitalized only the first letter of the first word---Emacs. I
downcased the rest.

> +      (description
> +       "This package provides a command embark-act (and a variant
> +embark-act-noexit), to execute actions on the top minibuffer completion
> +canidate: the one that would be chosen by minibuffer-force-complete")

I started the string "This package..." on the same line as description,
and added a period after minibuffer-force-complete.
diff mbox series

Patch

From 66d82a0666005301bc191c639cc3f5bcfc0fe5af Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Sun, 22 Nov 2020 14:39:11 +0100
Subject: [PATCH] gnu: Add emacs-embark.

* gnu/packages/emacs-xyz.scm (emacs-embark): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 885487bf17..6edf8ac99a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6719,6 +6719,34 @@  background of file-visiting buffers (and certain aspects of the UI) to make
 them easier to distinguish from other, less important buffers.")
     (license license:expat)))
 
+(define-public emacs-embark
+  ;; There are no tagged releases upstream on gitlab, instead we are using
+  ;; the most recent commit.
+  (let ((commit "dc20b4e53c4ce1ad91100dfeb093115f2cc0b210")
+        (revision "0"))
+    (package
+      (name "emacs-embark")
+      (version (git-version "0.6" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/oantolin/embark")
+               (commit commit)))
+         (sha256
+          (base32 "1jrvdlwip7zll5ixlnk9l0apr8hj60ysqfc47q3k4hhfyl9rawbq"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-avy" ,emacs-avy)))
+      (home-page "https://github.com/oantolin/embark")
+      (synopsis "Emacs Mini-Buffer Actions Rooted in Keymaps")
+      (description
+       "This package provides a command embark-act (and a variant
+embark-act-noexit), to execute actions on the top minibuffer completion
+canidate: the one that would be chosen by minibuffer-force-complete")
+      (license license:gpl3+))))
+
 (define-public emacs-prescient
   (package
     (name "emacs-prescient")
-- 
2.28.0