diff mbox series

[bug#46223,2/2] gnu: opencolorio: Update to 2.0.0.

Message ID 8735yg49sg.fsf@gmail.com
State New
Headers show
Series [bug#46223,1/2] gnu: opencolorio: Update to 2.0.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Evan Straw Feb. 1, 2021, 5:49 a.m. UTC

Comments

Efraim Flashner Feb. 1, 2021, 8:37 a.m. UTC | #1
Do both versions of blender build with this version of opencolorio?

On Sun, Jan 31, 2021 at 09:49:35PM -0800, Evan Straw wrote:
> From f981dc8fda53e116097f662c62cb2f1e7d740742 Mon Sep 17 00:00:00 2001
> From: Evan Straw <evan.straw99@gmail.com>
> Date: Sun, 31 Jan 2021 18:38:54 -0800
> Subject: [PATCH 2/2] gnu: opencolorio: Update to 2.0.0.
> 
> * gnu/packages/image-processing.scm (opencolorio): Update to 2.0.0.

There are other changes to the package. the source snippet is removed,
custom phase is removed, inputs are changed. They should be mentioned
also.

> ---
>  gnu/packages/image-processing.scm | 57 +++++++++----------------------
>  1 file changed, 17 insertions(+), 40 deletions(-)
> 
> diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
> index c3ea8491d9..9f3a420eea 100644
> --- a/gnu/packages/image-processing.scm
> +++ b/gnu/packages/image-processing.scm
> @@ -44,6 +44,7 @@
>    #:use-module (gnu packages boost)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages compression)
> +  #:use-module (gnu packages cpp)
>    #:use-module (gnu packages curl)
>    #:use-module (gnu packages docbook)
>    #:use-module (gnu packages documentation)
> @@ -70,6 +71,7 @@
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages qt)
>    #:use-module (gnu packages serialization)
> +  #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages tbb)
>    #:use-module (gnu packages tls)
> @@ -173,7 +175,7 @@ of external libraries that provide additional functionality.")
>  (define-public opencolorio
>    (package
>      (name "opencolorio")
> -    (version "1.1.1")
> +    (version "2.0.0")
>      (source
>       (origin
>         (method git-fetch)
> @@ -181,51 +183,27 @@ of external libraries that provide additional functionality.")
>               (url "https://github.com/AcademySoftwareFoundation/OpenColorIO")
>               (commit (string-append "v" version))))
>         (sha256
> -        (base32 "12srvxca51czpfjl0gabpidj9n84mw78ivxy5w75qhq2mmc798sb"))
> -       (file-name (git-file-name name version))
> -       (modules '((guix build utils)))
> -       (snippet
> -        `(begin
> -           ;; Remove bundled tarballs, patches, and .jars(!).  XXX: Upstream
> -           ;; claims to have fixed USE_EXTERNAL_YAML, but it still fails with:
> -           ;; https://github.com/AcademySoftwareFoundation/OpenColorIO/issues/517
> -           ;; When removing it, also remove it from the licence field comment.
> -           (for-each delete-file-recursively
> -                     (filter
> -                      (lambda (full-name)
> -                        (let ((file (basename full-name)))
> -                          (not (or (string-prefix? "yaml-cpp-0.3" file)
> -                                   (string=? "unittest.h" file)))))
> -                      (find-files "ext" ".*")))
> -
> -           #t))))
> +        (base32 "0888fca8wa5zdc6f7lmh1wi7ljw75ql0rlzaslk2zffd08ij0s38"))
> +       (file-name (git-file-name name version))))
>      (build-system cmake-build-system)
>      (arguments
>       `(#:configure-flags
> -       (list (string-append "-DCMAKE_CXX_FLAGS="
> -                            "-Wno-error=deprecated-declarations "
> -                            "-Wno-error=unused-function")
> -             "-DOCIO_BUILD_STATIC=OFF"
> -             ;; "-DUSE_EXTERNAL_YAML=ON"
> -             "-DUSE_EXTERNAL_TINYXML=ON"
> -             "-DUSE_EXTERNAL_LCMS=ON")
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'patch-test-suite
> -           (lambda _
> -             (substitute* "src/core_tests/CMakeLists.txt"
> -               (("/bin/sh") (which "bash")))
> -             #t)))))
> +       (list "-DOCIO_INSTALL_EXT_PACKAGES=NONE"
> +             (string-append "-Dpystring_ROOT="
> +                            (assoc-ref %build-inputs "pystring")))))
>      (native-inputs
>       `(("git" ,git)
> -       ("pkg-config" ,pkg-config)))
> +       ("pkg-config" ,pkg-config)
> +       ("python" ,python)))
>      (inputs
> -     ;; XXX Adding freeglut, glew, ilmbase, mesa, and openimageio for
> -     ;; ocioconvert fails: error: conflicting declaration ?typedef void
> -     ;; (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)
>       `(("lcms" ,lcms)
>         ("openexr" ,openexr)
> -       ("tinyxml" ,tinyxml)))
> +       ("tinyxml" ,tinyxml)
> +       ("expat" ,expat)
> +       ("pybind11" ,pybind11)
> +       ("yaml-cpp" ,yaml-cpp)
> +       ("ilmbase" ,ilmbase)
> +       ("pystring" ,pystring)))

Please sort the inputs alphabetically

>      (home-page "https://opencolorio.org")
>      (synopsis "Color management for visual effects and animation")
>      (description
> @@ -238,8 +216,7 @@ back-end configuration options suitable for high-end production usage.
>  OCIO is compatible with the @acronym{ACES, Academy Color Encoding
>  Specification} and is @acronym{LUT, look-up table}-format agnostic, supporting
>  many popular formats.")
> -    (license (list license:expat        ; docs/ociotheme/static, ext/yaml-cpp-*
> -                   license:zlib         ; src/core/md5
> +    (license (list license:zlib         ; src/OpenColorIO/md5
>                     license:bsd-3))))    ; the rest
>  
>  (define-public vtk
> -- 
> 2.25.1
>
diff mbox series

Patch

From f981dc8fda53e116097f662c62cb2f1e7d740742 Mon Sep 17 00:00:00 2001
From: Evan Straw <evan.straw99@gmail.com>
Date: Sun, 31 Jan 2021 18:38:54 -0800
Subject: [PATCH 2/2] gnu: opencolorio: Update to 2.0.0.

* gnu/packages/image-processing.scm (opencolorio): Update to 2.0.0.
---
 gnu/packages/image-processing.scm | 57 +++++++++----------------------
 1 file changed, 17 insertions(+), 40 deletions(-)

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index c3ea8491d9..9f3a420eea 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -44,6 +44,7 @@ 
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
@@ -70,6 +71,7 @@ 
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tbb)
   #:use-module (gnu packages tls)
@@ -173,7 +175,7 @@  of external libraries that provide additional functionality.")
 (define-public opencolorio
   (package
     (name "opencolorio")
-    (version "1.1.1")
+    (version "2.0.0")
     (source
      (origin
        (method git-fetch)
@@ -181,51 +183,27 @@  of external libraries that provide additional functionality.")
              (url "https://github.com/AcademySoftwareFoundation/OpenColorIO")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "12srvxca51czpfjl0gabpidj9n84mw78ivxy5w75qhq2mmc798sb"))
-       (file-name (git-file-name name version))
-       (modules '((guix build utils)))
-       (snippet
-        `(begin
-           ;; Remove bundled tarballs, patches, and .jars(!).  XXX: Upstream
-           ;; claims to have fixed USE_EXTERNAL_YAML, but it still fails with:
-           ;; https://github.com/AcademySoftwareFoundation/OpenColorIO/issues/517
-           ;; When removing it, also remove it from the licence field comment.
-           (for-each delete-file-recursively
-                     (filter
-                      (lambda (full-name)
-                        (let ((file (basename full-name)))
-                          (not (or (string-prefix? "yaml-cpp-0.3" file)
-                                   (string=? "unittest.h" file)))))
-                      (find-files "ext" ".*")))
-
-           #t))))
+        (base32 "0888fca8wa5zdc6f7lmh1wi7ljw75ql0rlzaslk2zffd08ij0s38"))
+       (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
-       (list (string-append "-DCMAKE_CXX_FLAGS="
-                            "-Wno-error=deprecated-declarations "
-                            "-Wno-error=unused-function")
-             "-DOCIO_BUILD_STATIC=OFF"
-             ;; "-DUSE_EXTERNAL_YAML=ON"
-             "-DUSE_EXTERNAL_TINYXML=ON"
-             "-DUSE_EXTERNAL_LCMS=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-test-suite
-           (lambda _
-             (substitute* "src/core_tests/CMakeLists.txt"
-               (("/bin/sh") (which "bash")))
-             #t)))))
+       (list "-DOCIO_INSTALL_EXT_PACKAGES=NONE"
+             (string-append "-Dpystring_ROOT="
+                            (assoc-ref %build-inputs "pystring")))))
     (native-inputs
      `(("git" ,git)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
     (inputs
-     ;; XXX Adding freeglut, glew, ilmbase, mesa, and openimageio for
-     ;; ocioconvert fails: error: conflicting declaration ?typedef void
-     ;; (* PFNGLGETFRAGMENTMATERIALFVSGIXPROC)(GLenum, GLenum, GLfloat*)
      `(("lcms" ,lcms)
        ("openexr" ,openexr)
-       ("tinyxml" ,tinyxml)))
+       ("tinyxml" ,tinyxml)
+       ("expat" ,expat)
+       ("pybind11" ,pybind11)
+       ("yaml-cpp" ,yaml-cpp)
+       ("ilmbase" ,ilmbase)
+       ("pystring" ,pystring)))
     (home-page "https://opencolorio.org")
     (synopsis "Color management for visual effects and animation")
     (description
@@ -238,8 +216,7 @@  back-end configuration options suitable for high-end production usage.
 OCIO is compatible with the @acronym{ACES, Academy Color Encoding
 Specification} and is @acronym{LUT, look-up table}-format agnostic, supporting
 many popular formats.")
-    (license (list license:expat        ; docs/ociotheme/static, ext/yaml-cpp-*
-                   license:zlib         ; src/core/md5
+    (license (list license:zlib         ; src/OpenColorIO/md5
                    license:bsd-3))))    ; the rest
 
 (define-public vtk
-- 
2.25.1