diff mbox series

[bug#47208] gnu: Add emacs-ivy-avy.

Message ID 8735wuurzp.fsf@posteo.net
State Accepted
Headers show
Series [bug#47208] gnu: Add emacs-ivy-avy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev March 17, 2021, 8:03 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

Comments

Jelle Licht March 22, 2021, 9:06 p.m. UTC | #1
Alexandr Vityazev <avityazev@posteo.org> writes:

> ---
>  gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
>  1 file changed, 23 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index bedfd61fc7..c73b0df283 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -90,7 +90,7 @@
>  ;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
>  ;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
>  ;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
> -;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
> +;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
>  ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
>  ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
>  ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
> @@ -27225,3 +27225,25 @@ and prefered services can easily be configured.")
>         "This package provides an Elisp wrapper around the Java
>  @command{keytool} command and major mode for viewing Java keystores.")
>        (license license:expat))))
> +
> +(define-public emacs-ivy-avy
> +  (package
> +    (name "emacs-ivy-avy")
> +    (version "0.13.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://elpa.gnu.org/packages/"
> +             "ivy-avy-" version ".tar"))
> +       (sha256
> +        (base32 "1q5caxm4rnh4jy5n88dhkdbx1afsshmfki5dl8xsqbdb3y0zq7yi"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-ivy" ,emacs-ivy)
> +       ("emacs-avy" ,emacs-avy)))
> +    (home-page "https://github.com/abo-abo/swiper")
> +    (synopsis "Avy integration for Ivy")
> +    (description
> +     "This package adds a \"C-'\" binding to Ivy minibuffer that uses Avy.")
> +    (license license:gpl3+)))
> -- 
> 2.30.2
>
>
>
> -- 
>
> Alexandr Vityazev

Pushed to master as b246420e40, with slightly tweaked commit message. Thanks!
 - Jelle
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bedfd61fc7..c73b0df283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -90,7 +90,7 @@ 
 ;;; Copyright © 2020 Jonathan Rostran <rostranjj@gmail.com>
 ;;; Copyright © 2020, 2021 Noah Evans <noah@nevans.me>
 ;;; Copyright © 2020 Brit Butler <brit@kingcons.io>
-;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
+;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -27225,3 +27225,25 @@  and prefered services can easily be configured.")
        "This package provides an Elisp wrapper around the Java
 @command{keytool} command and major mode for viewing Java keystores.")
       (license license:expat))))
+
+(define-public emacs-ivy-avy
+  (package
+    (name "emacs-ivy-avy")
+    (version "0.13.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/"
+             "ivy-avy-" version ".tar"))
+       (sha256
+        (base32 "1q5caxm4rnh4jy5n88dhkdbx1afsshmfki5dl8xsqbdb3y0zq7yi"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-ivy" ,emacs-ivy)
+       ("emacs-avy" ,emacs-avy)))
+    (home-page "https://github.com/abo-abo/swiper")
+    (synopsis "Avy integration for Ivy")
+    (description
+     "This package adds a \"C-'\" binding to Ivy minibuffer that uses Avy.")
+    (license license:gpl3+)))