diff mbox series

[bug#47873] gnu: Add emacs-ibuffer-vc.

Message ID 8735vnzj1w.fsf@posteo.net
State Accepted
Headers show
Series [bug#47873] gnu: Add emacs-ibuffer-vc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev April 18, 2021, 3:52 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou April 23, 2021, 9:10 a.m. UTC | #1
Hello,

Alexandr Vityazev <avityazev@posteo.org> writes:

> ---
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

Thank you.

I moved the package definition elsewhere than the end of the file (to
prevent merge conflicts), added a proper commit message, made the
changes below and applied your patch.

> +    (synopsis
> +     "Group ibuffer's list by VC project, or show VC status")

I detailed what meant "VC".

> +    (description
> +     "Adds functionality to ibuffer for grouping buffers by their parent
> +vc root directory, and for displaying and/or sorting by the vc
> +status of listed files.")

Description ought to be a complete sentence, and therefore, cannot start
with "Adds". I reworded it accordingly.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c449eb606..9074faf83b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27668,3 +27668,27 @@  quasi-prefix map, with many useful bindings.  These bindings are
 shorter than usual, using mostly unprefixed keys.")
     (license license:gpl3+)))
 
+(define-public emacs-ibuffer-vc
+  (package
+    (name "emacs-ibuffer-vc")
+    (version "0.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purcell/ibuffer-vc")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1mgn7b786j4hwq1ks012hxxgvrfn5rz90adi2j190gmjz60rc5g5"))))
+    (build-system emacs-build-system)
+    (home-page
+     "https://github.com/purcell/ibuffer-vc")
+    (synopsis
+     "Group ibuffer's list by VC project, or show VC status")
+    (description
+     "Adds functionality to ibuffer for grouping buffers by their parent
+vc root directory, and for displaying and/or sorting by the vc
+status of listed files.")
+    (license license:gpl3+)))