diff mbox series

bug#48640: Cbc (COIN-OR)

Message ID 8735u6ipfx.fsf@gnu.org
State Accepted
Headers show
Series bug#48640: Cbc (COIN-OR) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès May 28, 2021, 8:16 p.m. UTC
Hi Eric,

"Eric Brown" <ecbrown@ericcbrown.com> skribis:

> From b48d0a90603b7b2b8263c2e86e45b33cf787974c Mon Sep 17 00:00:00 2001
> From: Eric Brown <ecbrown@ericcbrown.com>
> Date: Tue, 25 May 2021 00:58:50 -0500
> Subject: [PATCH] gnu: Add cbc.
>
> * gnu/packages/maths.scm (cbc): New variable.

Applied with the changes below: returning #t at the end of
phases/snippets is no longer necessary, and mentioning “open source” is
unnecessary as well since everything in here is free software.  :-)

Thanks!

Ludo’.

Comments

Eric Brown May 30, 2021, 7:36 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> writes:
>
> Applied with the changes below: returning #t at the end of
> phases/snippets is no longer necessary, and mentioning “open source” is
> unnecessary as well since everything in here is free software.  :-)
>
> Thanks!
>
> Ludo’.

Roger that, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 614eacfccf..59598a242d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1812,9 +1812,7 @@  interfaces.")
               (modules '((guix build utils)))
               (snippet
                ;; Make sure we don't use the bundled software.
-               '(begin
-                  (delete-file-recursively "ThirdParty")
-                  #t))))
+               '(delete-file-recursively "ThirdParty"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("gfortran" ,gfortran)
@@ -1822,11 +1820,11 @@  interfaces.")
     (inputs
      `(("openblas" ,openblas)))
     (home-page "https://www.coin-or.org")
-    (synopsis "Branch-and-Cut solver")
+    (synopsis "Branch-and-cut solver")
     (description
-     "Cbc (Coin-or branch and cut) is an open-source mixed integer linear
-programming solver written in C++. It can be used as a callable library or
-using a stand-alone executable.")
+     "Cbc (Coin-or branch and cut) is a mixed integer linear programming
+solver written in C++.  It can be used as a library or as a standalone
+executable.")
     (license license:epl1.0)))
 
 (define-public clp