diff mbox series

[bug#48795] gnu: pioneer: Build with model files.

Message ID 8735u0nlw1.fsf@GlaDOS.home
State Accepted
Headers show
Series [bug#48795] gnu: pioneer: Build with model files. | expand

Commit Message

Diego Nicola Barbato June 2, 2021, 6:48 p.m. UTC
Hey Guix,

According to a comment on an issue on GitHub [1] pioneer now (version
20210203) has to be compiled with `make all build-data' when doing a
release build.  Otherwise the game fails to start with the following
error:

  Fatal: Error while loading Space Station data (check stdout/output.txt).

The attached patch adds the required make-flags and fixes
https://bugs.gnu.org/48686.

Regards,

Diego

[1]: https://github.com/pioneerspacesim/pioneer/issues/5138#issuecomment-773820174

Comments

Nicolas Goaziou June 2, 2021, 7:43 p.m. UTC | #1
Hello,

Diego Nicola Barbato <dnbarbato@posteo.de> writes:

> According to a comment on an issue on GitHub [1] pioneer now (version
> 20210203) has to be compiled with `make all build-data' when doing a
> release build.  Otherwise the game fails to start with the following
> error:
>
>   Fatal: Error while loading Space Station data (check stdout/output.txt).
>
> The attached patch adds the required make-flags and fixes
> https://bugs.gnu.org/48686.

Applied. Thank you.

Regards,
diff mbox series

Patch

From ca5cbf054c44150a74c1c31565019996b1aa9e9c Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Thu, 25 Feb 2021 10:00:13 +0100
Subject: [PATCH] gnu: pioneer: Build with model files.

Fixes <https://bugs.gnu.org/48686>.

* gnu/packages/games.scm (pioneer)[arguments]: Add make-flags for building
with model files.
---
 gnu/packages/games.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6b16d5bc8a..2eaea5868e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7293,7 +7293,8 @@  elements to achieve a simple goal in the most complex way possible.")
      `(#:tests? #f                      ;tests are broken
        #:configure-flags (list "-DUSE_SYSTEM_LIBLUA:BOOL=YES"
                                (string-append "-DPIONEER_DATA_DIR="
-                                              %output "/share/games/pioneer"))))
+                                              %output "/share/games/pioneer"))
+       #:make-flags (list "all" "build-data")))
     (home-page "https://pioneerspacesim.net")
     (synopsis "Game of lonely space adventure")
     (description
-- 
2.31.1