diff mbox series

[bug#49284,v2] gnu: Add fheroes2

Message ID 8735szveq6.fsf@trop.in
State Accepted
Headers show
Series [bug#49284,v2] gnu: Add fheroes2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Tropin June 30, 2021, 10:17 a.m. UTC
* gnu/packages/games.scm (fheroes2): New variable.
---
 gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 83cb738b9c..82595b64b9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12511,3 +12511,34 @@  wreckage.  You're stranded on a desert island and have to survive.  In order to
 do so you need to explore the island, find food, build a shelter and try to
 get attention, so you get found.")
       (license license:cc-by4.0))))
+
+(define-public fheroes2
+  (package
+    (name "fheroes2")
+    (version "0.9.4")
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags '("FHEROES2_STRICT_COMPILATION=1"
+                      "RELEASE=1")))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)))
+    (inputs
+     `(("zlib" ,zlib)
+       ("libpng" ,libpng)
+       ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ihhub/fheroes2")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0a3xi3k7ngp0byhmg7wq22l1hix3jwr68prk2y6frqhzbfskrvyg"))))
+    (home-page "https://ihhub.github.io/fheroes2/")
+    (synopsis "Turn-based strategy game engine")
+    (description "Free implementation of Heroes of Might and Magic II (aka
+HOMM2) game engine.  Requires assets/game resources to play, @file{fheroes2}
+is looking for them at @file{~/.local/share/fheroes2} folder.")
+    (license license:gpl2)))