diff mbox series

[bug#51948] Meson needs proper wrapping

Message ID 8735nrahwc.fsf@planete-kraus.eu
State Accepted
Headers show
Series [bug#51948] Meson needs proper wrapping | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vivien Kraus Nov. 19, 2021, 10:34 p.m. UTC
Ludovic Courtès <ludo@gnu.org> writes:
>> I pushed an update that does precisely that. Is the name "meson-wrapped"
>> OK? Also, how can I influence guix to rather install the wrapped version
>> when the user invokes "guix install meson"?
>
> I you just add another meson@0.60 package like this patch does, the UI
> will complain that “meson@0.60” is ambiguous, that there are two of them.
>
> To work around it, I’d mark the unwrapped meson@0.60 as hidden (using
> the ‘properties’ field) while keeping the other one visible.
>
> That way “guix install meson” will install the wrapped one.

I think that’s good: I build it with guix shell meson or guix build
meson, and I can run its absolute file name in a guix shell --pure
gcc. However, it does not seem to cause a world rebuild.

Vivien

Comments

Ludovic Courtès Nov. 22, 2021, 9:44 p.m. UTC | #1
Hi,

Vivien Kraus <vivien@planete-kraus.eu> skribis:

> From 3f77d8d5c652725411a21434443cbf2a2d135575 Mon Sep 17 00:00:00 2001
> From: Vivien Kraus <vivien@planete-kraus.eu>
> Date: Thu, 18 Nov 2021 15:17:52 +0100
> Subject: [PATCH] gnu: meson: Extend the python path in the installed program.
>
> * gnu/packages/build-tools.scm (meson-wrapped): New variable.

Applied, thanks!

As discussed on IRC, I followed up with a patch that moves Python from
‘propagated-inputs’ (!) to ‘inputs’ in ‘meson-wrapped’.  Most likely
Python was propagated just for the sake of setting GUIX_PYTHONPATH, but
it’s bad style as it forces it into user profiles.

Ludo’.
diff mbox series

Patch

From 3f77d8d5c652725411a21434443cbf2a2d135575 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Thu, 18 Nov 2021 15:17:52 +0100
Subject: [PATCH] gnu: meson: Extend the python path in the installed program.

* gnu/packages/build-tools.scm (meson-wrapped): New variable.
---
 gnu/packages/build-tools.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 849101c2a4..6a8a9c6f66 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -287,6 +287,7 @@  (define-public meson
     (inputs `(("ninja" ,ninja)))
     (propagated-inputs `(("python" ,python)))
     (home-page "https://mesonbuild.com/")
+    (properties '((hidden? . #t)))
     (synopsis "Build system designed to be fast and user-friendly")
     (description
      "The Meson build system is focused on user-friendliness and speed.
@@ -297,6 +298,29 @@  (define-public meson
 resembles Python.")
     (license license:asl2.0)))
 
+(define-public meson-wrapped
+  (package/inherit meson
+    (arguments
+     `(;; FIXME: Tests require many additional inputs and patching many
+       ;; hard-coded file system locations in "run_unittests.py".
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  ;; Meson calls the various executables in out/bin through the
+                  ;; Python interpreter, so we cannot use the shell wrapper.
+                  (replace 'wrap
+                    (lambda* (#:key outputs inputs #:allow-other-keys)
+                      (let ((python-version
+                             (python-version (assoc-ref inputs "python")))
+                            (output (assoc-ref outputs "out")))
+                        (substitute* (string-append output "/bin/meson")
+                          (("# EASY-INSTALL-ENTRY-SCRIPT")
+                           (format #f "\
+import sys
+sys.path.insert(0, '~a/lib/python~a/site-packages')
+# EASY-INSTALL-ENTRY-SCRIPT"
+                                   output python-version)))))))))
+    (properties '())))
+
 ;;; This older Meson variant is kept for now for gtkmm and others that may
 ;;; have problems with 0.60.
 (define-public meson-0.59
-- 
2.34.0