diff mbox

[bug#53582,0/2] Update obs to 27.1.3 and use new package style.

Message ID 8735l99y3s.fsf@trop.in
State Accepted
Headers show

Commit Message

Andrew Tropin Jan. 27, 2022, 12:10 p.m. UTC
Andrew Tropin (2):
  gnu: obs: Update to 27.1.3.
  gnu: obs: Use new package style.

 gnu/packages/video.scm | 32 ++++++++++++++++----------------
 1 file changed, 16 insertions(+), 16 deletions(-)

Comments

Leo Famulari Jan. 28, 2022, 8:29 p.m. UTC | #1
On Thu, Jan 27, 2022 at 03:10:16PM +0300, Andrew Tropin wrote:
> From c985af51a431656ad5e9389b9f8f132e7ac193b7 Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Thu, 27 Jan 2022 13:09:07 +0300
> Subject: [PATCH 1/2] gnu: obs: Update to 27.1.3.
> 
> * gnu/packages/video.scm (obs): Update to 27.1.3.

Thanks! I pushed this patch as 10d1125f71205f094a6030c51c498b0f8dab5f73

> From eb09c0cf30606564e3794b7a0afe409e0b48a9a1 Mon Sep 17 00:00:00 2001
> From: Andrew Tropin <andrew@trop.in>
> Date: Thu, 27 Jan 2022 14:54:22 +0300
> Subject: [PATCH 2/2] gnu: obs: Use new package style.
> 
> * gnu/packages/video.scm (obs): Use new package style.

I did not push this patch, because it only changes some elements to the
new style.

It still uses the old style of inputs (with labels) and it also
continues to use labels in the arguments, for example for "out".

Instead of (assoc-ref outputs "out"), you should use the gexp #$output.

Can you send a revised patch to address those issues?
diff mbox

Patch

From eb09c0cf30606564e3794b7a0afe409e0b48a9a1 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 27 Jan 2022 14:54:22 +0300
Subject: [PATCH 2/2] gnu: obs: Use new package style.

* gnu/packages/video.scm (obs): Use new package style.
---
 gnu/packages/video.scm | 28 ++++++++++++++--------------
 1 file changed, 14 insertions(+), 14 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3ab34812f2..932fb9165d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3337,21 +3337,21 @@  (define-public obs
                (search-patches "obs-modules-location.patch"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "-DOBS_VERSION_OVERRIDE=" ,version)
-             "-DENABLE_UNIT_TESTS=TRUE"
-             ;; Browser plugin requires cef, but it is not packaged yet.
-             ;; <https://bitbucket.org/chromiumembedded/cef/src/master/>
-             "-DBUILD_BROWSER=FALSE")
+     (list
+      #:configure-flags
+      #~(list (string-append "-DOBS_VERSION_OVERRIDE=" #$version)
+              "-DENABLE_UNIT_TESTS=TRUE"
+              ;; Browser plugin requires cef, but it is not packaged yet.
+              ;; <https://bitbucket.org/chromiumembedded/cef/src/master/>
+              "-DBUILD_BROWSER=FALSE")
        #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'wrap-executable
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (plugin-path (getenv "QT_PLUGIN_PATH")))
-               (wrap-program (string-append out "/bin/obs")
-                 `("QT_PLUGIN_PATH" ":" prefix (,plugin-path))))
-             #t)))))
+       #~(modify-phases %standard-phases
+           (add-after 'install 'wrap-executable
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out"))
+                     (plugin-path (getenv "QT_PLUGIN_PATH")))
+                 (wrap-program (string-append out "/bin/obs")
+                   `("QT_PLUGIN_PATH" ":" prefix (,plugin-path)))))))))
     (native-search-paths
      (list (search-path-specification
             (variable "OBS_PLUGINS_DIRECTORY")
-- 
2.34.0