diff mbox series

[bug#53705] gnu: Add emacs-tempel

Message ID 8735l2fpb6.fsf@posteo.net
State Accepted
Headers show
Series [bug#53705] gnu: Add emacs-tempel | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Feb. 1, 2022, 5:51 p.m. UTC
Hello,

this patch adds the emacs-tempel package.

/Niklas

Comments

Nicolas Goaziou Feb. 6, 2022, 9:07 p.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> Hello,
>
> this patch adds the emacs-tempel package.

Thank you.

> +    (arguments
> +     (list #:tests? #f))

This is the default in Emacs build system, so I removed it.

> +    (synopsis "TempEl - Simple templates for Emacs")

I removed the first part of the synopsis.

> +    (description
> +     "Tempel is a tiny template package for Emacs, which uses the
> +syntax of the Emacs Tempo library.  However Tempo may be a bit
> +dusty here and there.  Therefore we present to you, Tempel, a
> +modernized implementation of Tempo.")

I reworded the description, as most of it was not useful (e.g.,
modernized implementation doesn't mean much).

Applied!

Regards,
diff mbox series

Patch

From b890556ed1a43968599caa55472766fbb8a50cd3 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Tue, 1 Feb 2022 18:49:29 +0100
Subject: [PATCH] gnu: Add emacs-tempel.

* gnu/packages/emacs-xyz.scm (emacs-tempel): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 865c7c4172..b88302d967 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12939,6 +12939,31 @@  (define-public emacs-pretty-mode
      "Emacs minor mode for redisplaying parts of the buffer as pretty symbols.")
     (license license:gpl3+)))
 
+(define-public emacs-tempel
+  (package
+    (name "emacs-tempel")
+    (version "0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/minad/tempel")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "16972j2qq03q65qszgjjkzl52f79hk007kyi249wg1bqhvfa59b6"))))
+    (arguments
+     (list #:tests? #f))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/minad/tempel")
+    (synopsis "TempEl - Simple templates for Emacs")
+    (description
+     "Tempel is a tiny template package for Emacs, which uses the
+syntax of the Emacs Tempo library.  However Tempo may be a bit
+dusty here and there.  Therefore we present to you, Tempel, a
+modernized implementation of Tempo.")
+    (license license:gpl3+)))
+
 (define-public emacs-yasnippet
   (package
     (name "emacs-yasnippet")
-- 
2.32.0