diff mbox series

[bug#53765,v2,08/18] gnu: Add clojure-tools-analyzer.

Message ID 8735jidq3y.fsf@reilysiegel.com
State New
Headers show
Series None | expand

Commit Message

Reily Siegel March 16, 2022, 12:44 p.m. UTC
* gnu/packages/clojure.scm (clojure-tools-analyzer): New variable.
---
 gnu/packages/clojure.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 5e93a14dbc..4d64d72f5a 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -643,6 +643,37 @@  (define-public clojure-tools-macro
     (home-page "https://github.com/clojure/tools.macro")
     (license license:epl1.0)))
 
+(define-public clojure-tools-analyzer
+  (package
+    (name "clojure-tools-analyzer")
+    (version "1.1.0")
+    (home-page "https://github.com/clojure/tools.analyzer")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "19cgxxbav3z3k62hwl34vbi3lilrs4vksa4j8lvswha8sdjs01vh"))))
+    (build-system clojure-build-system)
+    (arguments
+     '(#:source-dirs '("src/main/clojure")
+       #:test-dirs '("src/test/clojure")
+       #:doc-dirs '()))
+    (synopsis "Analyzer for Clojure code, written in Clojure and producing
+AST in EDN")
+    (description "An analyzer for host agnostic Clojure code, written in
+Clojure and producing AST in EDN.
+
+Note that the analyzer in this library should not to be used directly as it
+lacks any knowledge about host-specific special forms and it should only be
+considered as a building platform for host-specific analyzers.  Currently the
+following platform specific analyzers written on top of tools.analyzer exist:
+@code{tools.analyzer.jvm}, @code{tools.analyzer.js}")
+    (license license:epl1.0)))
+
 (define-public clojure-tools-cli
   (package
     (name "clojure-tools-cli")